RC Monster Trucks Discuss rc monster trucks in this forum

Please help!

Reply
Old 07-15-2011, 11:47 AM
  #1
Ristler
Thread Starter
 
Join Date: Jul 2011
Location: epic, SK, FINLAND
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Please help!

Hey guys i just bought my first nitro rc truck, and i cannot get it to start. it has fuel init and the pullstart is like stuck, it will go up but i dont wanna break it
When i take the glowplug out, it pulls normally but then it goes stuck again....... I'm very desperate.. and i checked if its flooded its not nothin fuel coming out of it
And the flywheel is very hard to move.. please help some guys told me to pre heat it with a hairdryer would it work??
btw if this is in the wrong section please move it.. i just need help
Ristler is offline  
Reply With Quote
Old 07-15-2011, 04:02 PM
  #2
Havoc06
 
Join Date: Nov 2008
Location: Chester, VA
Posts: 8
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

Hello, I am going to assume this is a new motor. A couple of things to do. First trying heating the motor with a hair dryer or heat gun before you try to start the motor. Second try leaving the glow plug loose (1 turn back from tight) until you get it started, then tighten it up. Also check your manual for help. Let me know if you need more help.
Havoc06 is offline  
Reply With Quote
Old 07-16-2011, 12:34 AM
  #3
Ristler
Thread Starter
 
Join Date: Jul 2011
Location: epic, SK, FINLAND
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

Thankyou. I'm going to try that and i'll let you know
Ristler is offline  
Reply With Quote
Old 07-16-2011, 01:19 AM
  #4
Ristler
Thread Starter
 
Join Date: Jul 2011
Location: epic, SK, FINLAND
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

Wow, when the glowplug is loose, the pullstart isnt moving at all if i dont reach into flywheel and move it (really hard to move it)
Ristler is offline  
Reply With Quote
Old 07-16-2011, 02:22 AM
  #5
Ristler
Thread Starter
 
Join Date: Jul 2011
Location: epic, SK, FINLAND
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

Ok thanks Havoc, i got it to start easily but now the glowplug doesnt glow. i hope it isnt broken charging my heater atm
Ristler is offline  
Reply With Quote
Old 07-16-2011, 07:04 AM
  #6
Ristler
Thread Starter
 
Join Date: Jul 2011
Location: epic, SK, FINLAND
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

The car started the first time i pulled the pullstart, (ofcourse i heated it up) and i let it idle for about a minute, and it stalled. now it wont start anymore. It's not flooded
Ristler is offline  
Reply With Quote
Old 07-17-2011, 04:27 AM
  #7
Havoc06
 
Join Date: Nov 2008
Location: Chester, VA
Posts: 8
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

Do you have another plug you can try?? If you don't, I would tell you to buy a couple. Once you get the motor started with the glow plug loose, tighten the plug. Also if the motor gets tight(that's when it hits Top Dead Center also known as the PINCH Point) loosen the plug and rotate the flywheel so the piston is at the bottom. That will make starting it much easier.
Havoc06 is offline  
Reply With Quote
Old 07-17-2011, 10:26 AM
  #8
Ristler
Thread Starter
 
Join Date: Jul 2011
Location: epic, SK, FINLAND
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

Okay it started now, and i drove slowly on my yard. I saw smoke from glow plug, is it the after run oil? or something bad? ( i put after run oil)
and btw i do not have a temp gun does the engine heating (Hair drier) overheat the engine?
Ristler is offline  
Reply With Quote
Old 07-17-2011, 06:38 PM
  #9
Havoc06
 
Join Date: Nov 2008
Location: Chester, VA
Posts: 8
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

No the hair dryer does not hurt it. Do not use anymore after run oil until you are finished breaking it in. Smoke from the glow plug just means there was oil or fuel left on it. Have you been able to run a tank thru yet.
Havoc06 is offline  
Reply With Quote
Old 07-18-2011, 12:09 AM
  #10
Ristler
Thread Starter
 
Join Date: Jul 2011
Location: epic, SK, FINLAND
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

Not yet
Ristler is offline  
Reply With Quote
Old 07-18-2011, 01:10 AM
  #11
Ristler
Thread Starter
 
Join Date: Jul 2011
Location: epic, SK, FINLAND
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

Wow, now my steering barely steers.................. always problems
Ristler is offline  
Reply With Quote
Old 07-19-2011, 12:21 PM
  #12
ejc34710
 
Join Date: Sep 2008
Location: brookville , OH
Posts: 490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Please help!

Probably just the receiver pack. Yea, they can get a little frustrating. When it gets to that point, walk away. Go do something else for a while and come back later when your clear headed and not POed.
ejc34710 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:08 AM.