Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 2 of 2

  1. #1

    Join Date
    Jul 2011
    Location
    chesterfield, UNITED KINGDOM
    Posts
    1
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Thunder Tiger SSK V2 break in problems

    Hi , im new here so ill keep it short and sweet
    Basicly i am in the process or breaking in my second hand Thunder Tiger SSK Version 2 and ive hit a few
    problems, the reason im breaking it in is because it has had a lining and piston replacement because the guy who
    i bought it off had overheated the engine and it had caused it too seize, i did the fix ok but today after the cars 5th tank of fuel
    i took it out with my other ssk to get the last part of the break in done, it was working fine unti it randomly cut out, i checked its
    temperature which was nice and cool , when i tried to restart it, it put up a fight, didnt want too start and when i finally got it going
    it was BUCKETING out smoke at idle, like a flood of blue smoke , it would also not accelerate, becauseit would cut out if i tried, the idle
    speed also kept increasing and increasing until it was like it was going to explode, i checked the main jet too make sure it wasnt blocked and i kept leaning it out,
    but still loads of blue smoke and refused to run, i did all the basic tuning checks, but im not sure what the problem is, does anyone have any suggestions for me.
    Oh well at least for once when i come back from our local park with the cars nothing is broken or smashed

    Thanks
    Luke

  2. #2

    Join Date
    Apr 2010
    Location
    Traverse City, MI
    Posts
    1,046
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Thunder Tiger SSK V2 break in problems


    ORIGINAL: lukeer31
    it was working fine unti it randomly cut out,
    Several possibilities. Its most likely too rich and the engine got too much fuel and bogged out and quit. Also could be the glow plug.

    i checked its temperature which was nice and cool ,
    Make sure it stays above 200F

    when i tried to restart it, it put up a fight, didnt want too start
    Engine was flooded. Take out the glow plug, turn the rc over and cycle the engine a few times to clear it out.

    when i finally got it going it was BUCKETING out smoke at idle, like a flood of blue smoke , it would also not accelerate, becauseit would cut out if i tried,
    Engine was WAY too rich, lean the HSN out in 1/8 turn increments until you're happy with the performance, but NOTuntil its broken in.

    the idlespeed also kept increasing and increasing until it was like it was going to explode,
    Turn the idle needle ccw until the idle is better

    i checked the main jet too make sure it wasnt blocked and i kept leaning it out,but still loads of blue smoke and refused to run, i did all the basic tuning checks, but im not sure what the problem is, does anyone have any suggestions for me.
    Some engines take a lot of leaning out until they run well, but be careful to not lean it out TOO much as that has its own set of issues.
    HPI Baja 5SC, TLR 8ight 2.0, Traxxas Stampede 4x4 VXL and one very pissed off wife.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 11:34 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.