RC Monster Trucks Discuss rc monster trucks in this forum

Thunder Tiger SSK V2 break in problems

Reply
Old 07-16-2011, 12:41 PM
  #1
lukeer31
Thread Starter
 
Join Date: Jul 2011
Location: chesterfield, UNITED KINGDOM
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Thunder Tiger SSK V2 break in problems

Hi , im new here so ill keep it short and sweet
Basicly i am in the process or breaking in my second hand Thunder Tiger SSK Version 2 and ive hit a few
problems, the reason im breaking it in is because it has had a lining and piston replacement because the guy who
i bought it off had overheated the engine and it had caused it too seize, i did the fix ok but today after the cars 5th tank of fuel
i took it out with my other ssk to get the last part of the break in done, it was working fine unti it randomly cut out, i checked its
temperature which was nice and cool , when i tried to restart it, it put up a fight, didnt want too start and when i finally got it going
it was BUCKETING out smoke at idle, like a flood of blue smoke , it would also not accelerate, becauseit would cut out if i tried, the idle
speed also kept increasing and increasing until it was like it was going to explode, i checked the main jet too make sure it wasnt blocked and i kept leaning it out,
but still loads of blue smoke and refused to run, i did all the basic tuning checks, but im not sure what the problem is, does anyone have any suggestions for me.
Oh well at least for once when i come back from our local park with the cars nothing is broken or smashed

Thanks
Luke
lukeer31 is offline  
Reply With Quote
Old 08-18-2011, 09:02 PM
  #2
Sigma.40
 
Join Date: Apr 2010
Location: Traverse City, MI
Posts: 1,048
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Thunder Tiger SSK V2 break in problems


Quote:
ORIGINAL: lukeer31
it was working fine unti it randomly cut out,
Several possibilities. Its most likely too rich and the engine got too much fuel and bogged out and quit. Also could be the glow plug.

Quote:
i checked its temperature which was nice and cool ,
Make sure it stays above 200F

Quote:
when i tried to restart it, it put up a fight, didnt want too start
Engine was flooded. Take out the glow plug, turn the rc over and cycle the engine a few times to clear it out.

Quote:
when i finally got it going it was BUCKETING out smoke at idle, like a flood of blue smoke , it would also not accelerate, becauseit would cut out if i tried,
Engine was WAY too rich, lean the HSN out in 1/8 turn increments until you're happy with the performance, but NOTuntil its broken in.

Quote:
the idlespeed also kept increasing and increasing until it was like it was going to explode,
Turn the idle needle ccw until the idle is better

Quote:
i checked the main jet too make sure it wasnt blocked and i kept leaning it out,but still loads of blue smoke and refused to run, i did all the basic tuning checks, but im not sure what the problem is, does anyone have any suggestions for me.
Some engines take a lot of leaning out until they run well, but be careful to not lean it out TOO much as that has its own set of issues.
Sigma.40 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:49 AM.