Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 2 of 2

  1. #1

    Join Date
    Feb 2009
    Location
    Central, NJ
    Posts
    210
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    2.5R Problems

    I recently purchased the 2.5R to go into my Nitro Stampede. After following all break-in procedures, the engine ran great. After about a half of gallon of gas (after break-in) I hit a tree around half throttle. There was little damage, The exhaust popped off where it is zip-tied, an easy fix, and the engine was still running. I brought it to me, shut it off and fixed the exhaust. The engine wouldn't start, so I replaced the glowplug, although it still wouldn't work. I can't figure out why. Around TDC, the engine feels very tight(as if it was flooded, although it isn't.) When I remove the glow plug, it spins fine, no hang up at the top. I feel like I am overlooking something.
    Thanks in advanced
    The Cub Brotherhood Member #20
    Ultra Sport Brotherhood #134

  2. #2
    controlliner's Avatar
    Join Date
    Mar 2009
    Location
    Kingston, NS, CANADA
    Posts
    1,118
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: 2.5R Problems

    After about that much fuel, the engine will need to be leaned out a bit. Break in settings are usually rich and the engine may not run well after it loosens up until you lean it out a bit.
    \"Keep it clean and not too lean\" Duke Fox


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 03:06 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.