RC Monster Trucks Discuss rc monster trucks in this forum

Noob Question with Video - I'm guessing I stripped my servo?

Reply
Old 12-13-2013, 01:15 PM
  #1
liquidrage
Thread Starter
 
Join Date: Nov 2013
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Noob Question with Video - I'm guessing I stripped my servo?

http://www.youtube.com/watch?v=shWK9...ature=youtu.be


It doesn't really turn correctly anymore. Sometimes it'll turn a bit, others it won't. Sometimes it'll turn and even after it turns the servo is still whrilling like it's trying to do stuff.


So really, there's no real way to fix these things I take it? It's on an Arrma Granite Mega. As I understand it I can just plob a Traxxas 2075 servo in there as a replacement?


Thoughts, help appreciated.


Thanks......


**EDIT**

OK, so I took it apart and the teeth on the part of the main gear that makes contact with the middle set of gears does seem off. Put it back together and basically if I steer to the left the main gear turns OK and functions normally. If I steer right the servo motor whines but the main gear doesn't turn. And it will whine forever unless I turn the main gear by hand to the right. I guess this is what the little stop does on the main gear inside is give it resistance and cuts the servo motor off. But since it doesn't spin when steering right it never cuts off. Odd that it's broke in only one direction but whatever. So I really have no idea what I'm doing but at least when I put it back together it was broke in the same way, so I got that going for me which is nice.

Last edited by liquidrage; 12-13-2013 at 04:15 PM.
liquidrage is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 12:55 PM.