RC Monster Trucks Discuss rc monster trucks in this forum

Brushless mt pirate

Reply
Old 01-18-2014, 02:57 PM
  #1
sparky 25
Thread Starter
 
sparky 25's Avatar
 
Join Date: May 2005
Location: Derry, IRELAND
Posts: 1,469
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Brushless mt pirate

Been out of rc for a little while,

but recently came across of these trucks cheap,

was surprised how little the truck was marked for a used truck, underside is almost like new,

striped the Diffs, cleaned the grease out and put 50k front and rear,

Jammin/ofna x2 crt centre diff and associated diff/motor mount,

only had to drill 1 hole in chassis to get the mount lined up,

the motor is a 4174 2150kv beeman motor, just waiting on my new v2 trackstar 150a esc to arrive,

Anyone run one of these trucks brushless?
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	55
Size:	257.7 KB
ID:	1959162   Click image for larger version

Name:	image.jpg
Views:	50
Size:	156.8 KB
ID:	1959163   Click image for larger version

Name:	image.jpg
Views:	50
Size:	204.6 KB
ID:	1959164   Click image for larger version

Name:	image.jpg
Views:	77
Size:	266.8 KB
ID:	1959166   Click image for larger version

Name:	image.jpg
Views:	75
Size:	246.3 KB
ID:	1959167  
sparky 25 is offline  
Reply With Quote
Old 01-23-2014, 08:55 AM
  #2
bean-a-reano
 
bean-a-reano's Avatar
 
Join Date: Sep 2006
Location: springfield, IL
Posts: 42
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

That is AWESOME!!! looks like a great truck to start with. It's cool to see the old nitros making a comeback.
bean-a-reano is offline  
Reply With Quote
Old 02-02-2014, 03:25 AM
  #3
sparky 25
Thread Starter
 
sparky 25's Avatar
 
Join Date: May 2005
Location: Derry, IRELAND
Posts: 1,469
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Battery tray and steering servo plate installed, just need my esc to arrive to get running,

il post a YouTube video when I get it running
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	48
Size:	219.7 KB
ID:	1964546   Click image for larger version

Name:	image.jpg
Views:	34
Size:	218.5 KB
ID:	1964547  
sparky 25 is offline  
Reply With Quote
Old 04-21-2014, 11:57 AM
  #4
sparky 25
Thread Starter
 
sparky 25's Avatar
 
Join Date: May 2005
Location: Derry, IRELAND
Posts: 1,469
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Got the truck finished,
found the stock tires to be very heavy and I didn't like the look of them, so came across a brand new set of kyosho mega force tires on ebay got the 4 for 7,

had to cut the opening larger as they were too tight on the rim,

used the stock monster pirate receiver box to house the esc in,
relocated it on top of the steering plate,
cut the side out and removed the lid to help with cooling,

Got a New v2 trackstar 150a esc,
soldered the wires to it and bench ran the truck, the esc worked as it should, but when I touched the steering the esc kept turning off,
i made myself a glitch buster, installed it and all bench testing worked perfectly,

trucks going for its first burst out tomorrow, I think it's going to be an animal lol
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	32
Size:	224.4 KB
ID:	1988719   Click image for larger version

Name:	image.jpg
Views:	47
Size:	262.8 KB
ID:	1988720   Click image for larger version

Name:	image.jpg
Views:	35
Size:	255.7 KB
ID:	1988721   Click image for larger version

Name:	image.jpg
Views:	48
Size:	249.8 KB
ID:	1988722   Click image for larger version

Name:	image.jpg
Views:	48
Size:	261.0 KB
ID:	1988723   Click image for larger version

Name:	image.jpg
Views:	32
Size:	269.5 KB
ID:	1988724  
sparky 25 is offline  
Reply With Quote
Old 04-29-2014, 09:14 AM
  #5
Ttowntoolman
 
Join Date: Jun 2007
Location: Theresa, WI
Posts: 587
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Looks good, how does she run?
Ttowntoolman is offline  
Reply With Quote
Old 04-29-2014, 10:28 AM
  #6
sparky 25
Thread Starter
 
sparky 25's Avatar
 
Join Date: May 2005
Location: Derry, IRELAND
Posts: 1,469
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

runs too damn fast really lol,

First time I tried the truck it sorta got out of control in the first minute after I squeezed the trigger a little too much,
and took an awkward tumble which broke a lower rear a arm,
upon looking at the break in the a arm there was an air pocket in the middle of the break in the arm,
so I suppose it was a factory flaw waiting to be discovered,

after replacing that I took it for a proper run out on a large Tarmac area,

the truck ran perfectly, but it's a lot over geared, I need to go way up in spurgear count,
I'm looking at going from a 46t spurgear to a 54t spur,

Im running a kyosho centre diff so any kyosho spur will fit giving me plenty of gearing options,

the way it runs now is the truck cogs very slightly on start off and then the top speed is insane,
with even the slightest blip of the throttle lifting the front wheels in the air at any speed,

all this on 4s lipo, il post a link to a video once I sort the gearing out some.
sparky 25 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:27 AM.