RC Monster Trucks Discuss rc monster trucks in this forum

Mega Force Troubles

Reply

Old 05-17-2004, 08:14 PM
  #1  
mike_p
Junior Member
Thread Starter
 
Join Date: Dec 2003
Location: Fort Lewis, WA
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Mega Force Troubles

I have a kyosho mega force that wont move forward without a serious grating sound. it kind of pops and shudders forward. i replaced the gears in the front and rear diff, checked the black diff box and no wear there. any help............ dont know what to do. no one works on Kyosho here in the tacoma area. any help would be appreciated
mike_p is offline  
Reply With Quote
Old 05-17-2004, 09:38 PM
  #2  
normanski
Senior Member
 
Join Date: Jul 2003
Location: Hong Kong, HONG KONG
Posts: 278
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Mega Force Troubles

Hello Mike_p,

I have worked on my friend's Mega-Force, and I have a Kyosho Dodge Ram. Both trucks have the Kyosho Quick Reverse Control, but I think the Mega Force has a much beefier unit.

The QRC does create some uncool noise when it engages. Will the truck run OK after the uncool noise? Any way, my friend did manage to strip the reverse gears by engaging the reverse while the truck was going forward at high speed. After that, the gearbox was very noisy as you described. My guess is your QRC gearbox is damaged. You can either replace the gears inside the gearbox( The big box that is right in front of the engine.) or use the FORWARD ONLY conversion that should come with the kit. Then the Mega-Force will only have forward & brake like any other trucks. Hope this is useful.

Normanski
normanski is offline  
Reply With Quote
Old 05-17-2004, 09:45 PM
  #3  
mike_p
Junior Member
Thread Starter
 
Join Date: Dec 2003
Location: Fort Lewis, WA
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Mega Force Troubles

the noise doesnt go away at all and the truck just creeps around if it moves at all. i opened the QRC and it is pristine inside. there was no wear (shavings) like you would see if it was coming apart. currently the truck is in the brake forward only mode. what about the possibility of a clutch tranny, or engine piston failure. i dont know much about them. when i was stationed in korea all i did was jsut take it to the local hobby shop and he fixed everyhting when needed. thanks for your insight
mike_p is offline  
Reply With Quote
Old 05-17-2004, 10:16 PM
  #4  
normanski
Senior Member
 
Join Date: Jul 2003
Location: Hong Kong, HONG KONG
Posts: 278
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Mega Force Troubles

Hello Mike_p,

When you increase the rpm of the engine, does the spur gear rotate? The Spur Gear is the big black plastic gear between the engine & the gear box. If it does, then you can try tightening the slipper clutch which is the spring loaded nut in the middle of the Spur Gear.

Normanski
normanski is offline  
Reply With Quote
Old 05-17-2004, 11:54 PM
  #5  
mike_p
Junior Member
Thread Starter
 
Join Date: Dec 2003
Location: Fort Lewis, WA
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Mega Force Troubles

i havent tried that. i will do so and let you know what happend. thanks
mike_p is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service