RC Monster Trucks Discuss rc monster trucks in this forum

Advice and factory settings for Sirio 27XL 11-Port

Reply

Old 09-08-2005, 06:55 PM
  #1  
FE_Chris
Thread Starter
My Feedback: (2)
 
FE_Chris's Avatar
 
Join Date: Jun 2005
Location: Barksdale AFB, LA
Posts: 2,420
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Advice and factory settings for Sirio 27XL 11-Port

Hi! I have a serio 27XL engine. First off, i purchased this engine used with only 5 tanks on a savage run through it, and all but 1 was for breakin i believe. But This is the thing. I don;t have the factory needle settings for the engine, so i do not know how to tune it. Anybody get them for me? I was told that the engine is a 10 port serio 27. I cannot find a 10 port serio on trinity's web site. I do know the engine takes a regular plug and not a turbo plug. I did get the engine to start and run for a couple minutes...it seemed to run OK, but it would not pull wheelies and it would sputter when i reached HI RPM's in first gear (have to ajust 2 speed yet). But then it quit once, and would not start back-up.. The temp guage i have read 239 degrees F. Is this too hot??? I did have blue smoke coming from the exhaust pipe at most times also.

The fuel i use is wild cat 20% nitro /18% oil. Castor blend. Wild cat is what the LHS sells. It's the fuel that i like to run in my SW36, i thaught it would work fine with this engine too. DO i have to much oil in the engine? shoudl i run 30% nitro or 40%? From what i read i purchased a real race engine. I would like it to run great, any help would be greatly appreciated.

Also, i checked the plug, and it is good, fresh battery's in the glow started also. Can a serio racer maybe reccomend a good glow plug for me? Thanks!

PS. I did try the "search button" before writing this post, i did not come up with much
FE_Chris is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service