RC Monster Trucks Discuss rc monster trucks in this forum

Help! New Sirio .18 wont start with EZ Start!

Reply

Old 04-25-2003, 04:47 AM
  #1  
lamp3y3
Member
Thread Starter
 
Join Date: Apr 2003
Location: Arlington, TX
Posts: 75
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Help! New Sirio .18 wont start with EZ Start!

I just bolted up the Sirio .18 and either I tightened the flywheel too tight or the engine has too much compression to start with the EZ Start system.

The engine tries to fire a few times then stops. I checked the flywheel and its very tight at that spot (could i overtighten?)

The EZ Start works for 5-10 seconds then the green motor light goes out and the case becomes warm. Its apparent the starter motor doesnt have enough power to crank the motor over and therefore shuts itself off.

I hate to spend 50+ on a traxxas pull start i saw on ebay.

Id rather buy some kind of adapter which will work with a power drill, but not sure if there is one for the 2.5. I know one for the older t maxx but will it fit the 2.5?

Anyone have this trouble or have any ideas please write.

What about Racers Edge Power Starter? Its for the .15
Anyone know if it will bolt up to the 2.5 / Sirio .18

http://www.rcnitro.com/rn/images/new...ower_start.jpg

losing the EZ start and freeing up space and weight sounds good
lamp3y3 is offline  
Reply With Quote
Old 04-25-2003, 12:52 PM
  #2  
BUGGIES_R_US
 
BUGGIES_R_US's Avatar
 
Join Date: Dec 2002
Location: Norcross, GA
Posts: 3,342
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Help! New Sirio .18 wont start with EZ Start!

I'll try to look for it but there was a really great article with pictures and all about how this guy did his. (here on RCU)

-ram
BUGGIES_R_US is offline  
Reply With Quote
Old 04-25-2003, 12:53 PM
  #3  
BUGGIES_R_US
 
BUGGIES_R_US's Avatar
 
Join Date: Dec 2002
Location: Norcross, GA
Posts: 3,342
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Help! New Sirio .18 wont start with EZ Start!

Bingo!
Here it is:

http://www.rcuniverse.com/showthread...xx+drill+start

Good luck!
-ramm
BUGGIES_R_US is offline  
Reply With Quote
Old 04-25-2003, 07:35 PM
  #4  
Avalanche
Senior Member
 
Join Date: Jan 2003
Location: NJ
Posts: 486
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Help! New Sirio .18 wont start with EZ Start!

Its not unusual for new engines to be VERY tight before they are broken in, especially performance engines. Loosen the glow plug 1/8 to 1/2 a turn to reduce compression a bit. After the engine fires up, tighten the plug down and continue with an easy break in. After a tank or two I bet it will start right up.
Avalanche is offline  
Reply With Quote
Old 04-25-2003, 07:50 PM
  #5  
BUGGIES_R_US
 
BUGGIES_R_US's Avatar
 
Join Date: Dec 2002
Location: Norcross, GA
Posts: 3,342
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Help! New Sirio .18 wont start with EZ Start!

True that..

MY engine was friggin impossible to start even with a starter box sometimes.

IT would just get jammed up top. I'd have to force it down and a few tanks later, it would "pop" down on its own.

-ram
BUGGIES_R_US is offline  
Reply With Quote
Old 04-26-2003, 06:32 AM
  #6  
lamp3y3
Member
Thread Starter
 
Join Date: Apr 2003
Location: Arlington, TX
Posts: 75
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Help! New Sirio .18 wont start with EZ Start!

Thanks for the tips guys! I got it started !

I should have thought of this but I didnt. I called my local hobby shop asking if they had a pullstart ( I actually already ordered one on EBay few days back just couldnt wait lol) Of course they didnt have a pullstart- they never have anything. Anyway he told me to use HAIRDRYER! AH! Im sure you guys knew this trick so did I but I didnt think of it. I even used a hairdryer last month to try to free my piston sleeve but it never would come out of the 2.5. I got to send that back for a new one.

Anyways, I took this puppy to the track today and man this Sirio hums. I think i got ear damage from trying to read my venom temp gauge mounted to my rear shock tower with the custom duals blazing . Now i have to get a sirio tuned pipe because these duals are crap for the track or bashing jumping etc. the header exhaust boot kept coming loose. the guy could have made a ridge in the pipe for the boot to slip over. I would look for this if you buy custom exhaust. Now I have to sell this as its only good for onroad and what fun is that

Lampeye
lamp3y3 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service