RC Monster Trucks Discuss rc monster trucks in this forum

Savage 21 engine running problem!

Reply

Old 06-15-2003, 07:21 PM
  #1  
Bacchuss
Member
Thread Starter
 
Join Date: Jun 2003
Location: LA
Posts: 35
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Savage 21 engine running problem!

I've got about 3/4 a gallon of fuel thru my savage. I decided to return the needles to factory and re-tune it up. I've got the high and low speed needles down to about 3 turns. Runs good good like that....hits second nice. BUT....the thing will not idle worth anything. The idle screw looks to be adjusted correctly...it always has a 2mm gap in it. If i let it idle for about 5 seconds it dies. I'm running blue thunder 20% in it. I'm thinking maybe it too rich or something because if i put it on a box and run it there ends up being a big pile of oil from the exhaust on the box in a matter of 2 minutes? Anyone have the same problem or any advice to try and follow?

Thanks in advance!
Bacchuss is offline  
Reply With Quote
Old 06-16-2003, 01:54 AM
  #2  
dirtdawg
Member
 
Join Date: Jan 2003
Location: turtle creek , pa
Posts: 33
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Savage 21 engine running problem!

make the idle faster and then retune it
dirtdawg is offline  
Reply With Quote
Old 06-16-2003, 01:59 AM
  #3  
cemeb4dk
Senior Member
 
cemeb4dk's Avatar
 
Join Date: May 2003
Location: St. Charles, IL
Posts: 1,014
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Savage 21 engine running problem!

I just replace my piston and sleeve, had to reset evrything back to factory, re broke in it idled fine. Then started to tune it again and it started happening. Have to start it give it gas right away and then let the car go, then its fine, but once i stop it doesn't idle long, maybe 30-45 seconds then dies. But now my trans blew i think, and i haven't really got it tuned in. I think its just to rich, because mine was getting better, as i was leaning it out.
cemeb4dk is offline  
Reply With Quote
Old 06-16-2003, 10:18 AM
  #4  
BUSH-MASTER
Member
 
Join Date: Apr 2003
Location: NAUGATUCK, CT
Posts: 54
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Savage 21 engine running problem!

blue thunder is very hard to tune the oil in it turns into a combustible if to lean and it makes you think its to rich the moter will flame out indicating to rich when its actually to lean
BUSH-MASTER is offline  
Reply With Quote
Old 06-16-2003, 07:56 PM
  #5  
Bacchuss
Member
Thread Starter
 
Join Date: Jun 2003
Location: LA
Posts: 35
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Savage 21 engine running problem!

got it...when i cleaned my air filter i re-oiled it with too much oil...engine of starviing of air at idle...just couldn't pull air thru too much oil...running AWESOME now...i love this thing!
Bacchuss is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service