RC Monster Trucks Discuss rc monster trucks in this forum

Trouble with my T-Maxx and JR radio shifter

Reply

Old 06-15-2003, 11:26 PM
  #1  
catboater
Thread Starter
My Feedback: (51)
 
catboater's Avatar
 
Join Date: Jan 2002
Location: Kirkland, WA
Posts: 543
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Trouble with my T-Maxx and JR radio shifter

I bought a new JR XRI 3 and installed the new rx in the truck. It worked fine at first but it has started to malfunction on its own. Sometimes at idle it'll go into neutral and won't engage forward when throttle is applied. Other times it won't shift back into forward after using reverse. When I check the linkages everything seems fine. Another guy was having the same problem with his XRS and neither one of us could make sense of it.
Anyone else have this problem ? Anyone have the answer?
catboater is offline  
Reply With Quote
Old 06-16-2003, 12:43 PM
  #2  
*Crash*Johnson*
Senior Member
My Feedback: (7)
 
*Crash*Johnson*'s Avatar
 
Join Date: Apr 2003
Location: Here, NJ
Posts: 1,089
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Trouble with my T-Maxx and JR radio shifter

I have the same problem with the stock radio. All friggin day yesterday reverse.....no foward......walk over and kick it back and screw with it for 20 minutes and finally get forward back....
Very frustrating...
*Crash*Johnson* is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service