RC Nitro Stadium Trucks Discuss all aspects of rc nitro stadium trucks here

Slayer pro issues

Reply
Old 11-05-2017, 04:29 PM
  #1
asome50
Thread Starter
 
Join Date: Dec 2011
Location: PhiladelphiaPennsylvania
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Slayer pro issues

I just purchased a Slayer Pro 4x4 from an ebay seller for $200. It came with .26 pico engine, the exhaust, and the big block engine mount. Included was also a 3.3 engine and ex start mounted. It arrived with a bolt holding the rear driver side turnbuckle lose and rolling around in the box. When I tried to attach that I found the bolt hole to be stripped out. It did not come with a radio but did come with a receiver. When I paired a transmitter from my new rustler (that is the most updated transmitter) i had problems. The throttle servo only actuates in the motion where it opens the carb. It goes from partial carb open to full braking. The only way to get the brake off is to actuate the throttle. The wheels also"drift" when the throttle is applied, the way a mixing transmitter would. I also have a couple other issues to fix but I can fix them on my own. The starter motor not turning (frayed ground wire), bad camber (easy fix), other body issues. Both servos are "savox" servos. The main issue I have is the steering servo drift and the problem with the brake/throttle. Any help would be greatly appreciated.
asome50 is offline  
Reply With Quote
Old 11-07-2017, 05:28 PM
  #2
Ncmayo
 
Join Date: Nov 2017
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

You should have a spring on your throttle to help pull throttle back to idle. Also check make sure batteries are good
Ncmayo is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:10 PM.