Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1

    Join Date
    Oct 2003
    Location
    durbannatal, SOUTH AFRICA
    Posts
    71
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    mt2 diff prob

    hi.i dont know why but my mt2 diffs are troubling me.i already put a 2 washers on the ecah diff.there was no play at all.after 4 tanks with my os 18 the diff started to slip again.does anyone have any solutions because this is really irratating me.
    zsar1

  2. #2

    Join Date
    Dec 2004
    Location
    Ipswich, suffolk, UNITED KINGDOM
    Posts
    330
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: mt2 diff prob

    Hi there.
    Search the 'Official MT2 thread' and all your answers will be complete.
    My Garage-

    http://www.srcoffroad.co.uk
    Losi-8T - Losi 8-B

  3. #3
    46u's Avatar
    Join Date
    Jan 2005
    Location
    Macon, GA
    Posts
    22,086
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: mt2 diff prob

    Make sure you run the heavy-duty gears and when shimming you need a little play. All so make sure you are running the cast metal spider gears and not the pot metal ones. All so make sure you have your slipper clutch set right.

    Here are some links

    http://www2.towerhobbies.com/cgi-bin...7&I=LXJYM2&P=K

    http://www2.towerhobbies.com/cgi-bin...?&I=LXBTA4&P=Z
    Rebel Racing


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 03:29 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.