Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Page 64 of 263 FirstFirst ... 1454626364656674114164 ... LastLast
Results 1,576 to 1,600 of 6551

  1. #1576

    Join Date
    Oct 2007
    Location
    , OR
    Posts
    340
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    I have found the flush settings work for me but when you tune it make like 1/16 turns. I have found if I lean it to much it just bogs cuz there is not enough fuel. I have mine leaned like a 1/8 of HSN and LSN, runs about 220 but my slipper cluth was slipping pretty bad need to tighten it up. Man I forgot how fun this thing is

  2. #1577

    Join Date
    Aug 2007
    Location
    Smithsburg, MD
    Posts
    124
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Well I have a first for all you guys. Here is the pic, I want you to do the guess's on how it happened...

    it really sucks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Rp43494.jpg 
Views:	7 
Size:	33.1 KB 
ID:	905227   Click image for larger version. 

Name:	Rn39415.jpg 
Views:	7 
Size:	32.4 KB 
ID:	905228  
    Paddle Faster I Think I hear Banjo Music.

  3. #1578

    Join Date
    Jan 2008
    Location
    O\'Fallon, IL
    Posts
    82
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Did your motor mounts just rip off?

  4. #1579

    Join Date
    Aug 2007
    Location
    Smithsburg, MD
    Posts
    124
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Well one side did
    Paddle Faster I Think I hear Banjo Music.

  5. #1580

    Join Date
    Jan 2008
    Location
    O\'Fallon, IL
    Posts
    82
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Jebus.

    what'd you do?

  6. #1581
    NitroNate's Avatar
    Join Date
    Jul 2007
    Location
    Honeybrook, PA
    Posts
    1,322
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-


    ORIGINAL: FirestormBasher

    Well I have a first for all you guys. Here is the pic, I want you to do the guess's on how it happened...

    it really sucks
    Now you have an excuse to get a shiny new O.S TZ.!
    BREWING UP A STORM
    HPI Firestorm W/CV-RX = Tank/Greased Lighting

  7. #1582

    Join Date
    Aug 2007
    Location
    Smithsburg, MD
    Posts
    124
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Well it was a huge bash that destroyed it. I was jumping with a 16' utillity trailer, using the ramps as the jump. It was going about 6' high and as far as 20 out. The last run I wan't going fast enough, turned on its end and motor took a straight shot on the railing of the trailer.

    For the new motor I was just going to put in a OEM G3.0. There selling new on ebay for 80 bucks. It was a sturdy, reliable engine so I'm stickin with it.
    Paddle Faster I Think I hear Banjo Music.

  8. #1583
    yakfish's Avatar
    Join Date
    Feb 2008
    Location
    Fairborn, OH
    Posts
    2,429
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    I just order 5 hpi r5 glow plugs from ebay for 4.99 each I figure with as fast as I'm burning thru them I may as well have a few extra on hand. I'm currently set the needles back to flush and then I'll start tuning over again and maybe I'll be able to save some plugs. yesterday I was running it around A bit and I broke one of the suspention arms (part#100312) does anyone know of this is available in aluminum. I'm thinking from now on whenever I break something I'll get the aluminum replacement part and after I while the whole car will be much stronger. It will add a little bit on weight but I'm not too concerned about that- I think I getting a OS tz engine!

  9. #1584
    yakfish's Avatar
    Join Date
    Feb 2008
    Location
    Fairborn, OH
    Posts
    2,429
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    So much for needing the OS engine. All I needed was the right tune. I just came in from doing a bit of tuning and man, this thing absoluty rips. I put everything back to factory flush and just went from there. HSN is about 1/2 to 3/4 turn from flush and the LSN is maybe 1/16 from flush. instant throttle response and nice cloud of smoke through the whole rpm band! If only I could get some traction! I can't wait for my new Moabs to get here!!

    BTW has any one ever tried running with an open header? I don't know if it would damage the engine or not but while I was runnig around with it and it slid sideways into the garage and knocked the muffler off olf the header you want to talk about loud! any of you ever do this before?

  10. #1585

    Join Date
    Jan 2008
    Location
    O\'Fallon, IL
    Posts
    82
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Happened at the track to me.

    The pipe actually adds some power/torque, so keep it on .

  11. #1586

    Join Date
    Jul 2007
    Location
    Essex, UNITED KINGDOM
    Posts
    93
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Yeah that happened to me over the park once...

    jumped a mound and it popped off! very loud though

  12. #1587

    Join Date
    Aug 2007
    Location
    Smithsburg, MD
    Posts
    124
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Yeah, it gets really loud when the manifold comes loose from the engine.
    Paddle Faster I Think I hear Banjo Music.

  13. #1588
    eirk66's Avatar
    Join Date
    Apr 2005
    Location
    Newbury park, CA
    Posts
    285
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    my little brother has a hpi firestorm and hes beaten it pretty good but now im not sure whats going on with it has a bump start to start it run fine put it on the ground and dies ..... would he need new clutch pads ? or something im not getting whats going on and ive tried adjusting the slipper clutch on it and im not new to rc just haven't played aroun to much with 2wd nitro's im thinkin maybe the pads are done on it due too if i loosen the clutch all the way engine runs fine then if i tighten it a little bit it dies....

  14. #1589

    Join Date
    Jan 2008
    Location
    O\'Fallon, IL
    Posts
    82
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    mine was doing the same thing last friday.

    I just used a different glo igniter and it worked, got home, and my normal one worked again...

    You idea of the slipper pads is something to look into as well.

  15. #1590

    Join Date
    Feb 2008
    Location
    arcade, NY
    Posts
    20
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    what is the replacement glow plug for the firestorm? thanks

  16. #1591

    Join Date
    Feb 2008
    Location
    , BC, CANADA
    Posts
    808
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-


    ORIGINAL: will0983

    what is the replacement glow plug for the firestorm? thanks
    many different one's will work. os #3 plug works well. the mccoy is a good plug to. i like the mccoy plug the best

  17. #1592
    eirk66's Avatar
    Join Date
    Apr 2005
    Location
    Newbury park, CA
    Posts
    285
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-


    ORIGINAL: Beater Of Angels

    mine was doing the same thing last friday.

    I just used a different glo igniter and it worked, got home, and my normal one worked again...
    naw that wouldn't cause it... thanks for sugestion though

  18. #1593

    Join Date
    Aug 2007
    Location
    Smithsburg, MD
    Posts
    124
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    I use an O.S. #8
    Paddle Faster I Think I hear Banjo Music.

  19. #1594
    NitroNate's Avatar
    Join Date
    Jul 2007
    Location
    Honeybrook, PA
    Posts
    1,322
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    eirk66,check the clutch spring,it could be broken.
    BREWING UP A STORM
    HPI Firestorm W/CV-RX = Tank/Greased Lighting

  20. #1595
    windowlicker's Avatar
    Join Date
    Feb 2008
    Location
    Barton, North Lincolnshire, UNITED KINGDOM
    Posts
    301
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Half way finished modding my Firestorm. All alloy parts, and graphite deck. Just need to polish my bent exhaust and straighten it out (must have hit it on a rock or something)





    More pics when I've finished!
    Hellfire SS - GO .25 - DX3R - 5955TG - 5645MG - Speedtech Carbon

  21. #1596

    Join Date
    Jul 2007
    Location
    Essex, UNITED KINGDOM
    Posts
    93
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    [X(][X(][X(]

    Love that car dude!

    where did you get your alloy arms from ? They look the business!

    Im going to paint my exhuast red next month...when i get paid

    Then add a new shiny black shell on it.... Nice stealth look im feeling

  22. #1597
    yakfish's Avatar
    Join Date
    Feb 2008
    Location
    Fairborn, OH
    Posts
    2,429
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    I just bought new suspention arms for mine yesterday.I asked the LHS about whether or not I could get them in aluminum. he said that they weren't available. where did you get yours and what did they cost? They look great!

  23. #1598

    Join Date
    Aug 2007
    Location
    Smithsburg, MD
    Posts
    124
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Make sure you ditch the phillips head screws on those arms. Take them out and put nice cap head screws in. I have the same setup and stripped all the screws.
    Paddle Faster I Think I hear Banjo Music.

  24. #1599
    windowlicker's Avatar
    Join Date
    Feb 2008
    Location
    Barton, North Lincolnshire, UNITED KINGDOM
    Posts
    301
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    I doubt I'll ever touch the phillip head screws on them.

    They are Hot Racing arms which I got from ebay, from a seller called Bizzare Hobbies or something. They cost me $23.79 for each pair (back and front) so $47 altogether.

    Thing is with them that at the ends of the rear arms, they are not machined down where the rear axles pass. This means that you have to set your suspension at the back quite slack, otherwise, if the rear suspension is pre-loaded and raised up, the axles touch the arms, locking the rear wheels. I straight away assumed that I would need the Hot Racing Hubs and so bought them. (Seen as though I was ordering to the UK, I decided to buy everything else too, such as the Upper Deck Mount, Brake Lever, Engine Mount etc) The ally hubs were no different so I now have to either drop the rear suspension or machine them myself. Luckily I have put 35wt oil in the front shocks and 40wt in the rear so even though I have dropped the ride height at the back, the suspension feels hard enough to not bottom out. When you replace the arms, front and back camber will be way off, so you'll have to reset the camber. After looking at most pics of Firestorms where the inside of the rear tyres seem to wear first, I decided to make the rear tyres have 0 camber, so they are perfectly flat on the ground, hope to see if this gives more grip!

    Another thing I was annoyed about was the 'Hot Racing Front Engine mount', which is not a engine mount at all, but the small cable guide block which fits under the engine, you can't see it and having this part alloy is absolutely pointless! I though I was going to be replacing the stock black engine mounts with silver ally ones but no! I highly recommend that you don't bother buying this part!

    Apart from that I am really happy with it, just need to get some paint stripper and sort my exhaust out, then I'll be ready to take it out again!
    Hellfire SS - GO .25 - DX3R - 5955TG - 5645MG - Speedtech Carbon

  25. #1600
    windowlicker's Avatar
    Join Date
    Feb 2008
    Location
    Barton, North Lincolnshire, UNITED KINGDOM
    Posts
    301
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: -=OFFICIAL HPI FIRESTORM THREAD=-

    Here is a photo of the rear axle and how it has scuffed the arm, if you look at your plastic arms, you will notice that part is cut away for the axle to pass, surely hot racing noticed that?!



    Here is the Upper deck mount:



    And here is the Dubro Fuel filter I fitted:

    Hellfire SS - GO .25 - DX3R - 5955TG - 5645MG - Speedtech Carbon


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 12:08 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.