RC Nitro Stadium Trucks Discuss all aspects of rc nitro stadium trucks here

Truck not going even at full throttle???

Reply
Old 02-04-2007, 12:51 PM
  #1
kneeno
Thread Starter
 
Join Date: Jan 2007
Location: watertown, WI
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Truck not going even at full throttle???

Hi-
Now that I finally got my truck started I'm having a problem getting it moving. When I give the truck gas with the remote the engine is screaming like it wants to go, but is barely even rolling. After letting off and on the gas for a few minutes with no success I shut it off and thought I better get some advice. Help!! Mike
kneeno is offline  
Reply With Quote
Old 02-04-2007, 02:16 PM
  #2
associatedelectric
 
Join Date: Sep 2006
Location: Grand Island, NY
Posts: 125
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Truck not going even at full throttle???

Make sure your slipper is tight. Are the gears moving when you give it gas?
associatedelectric is offline  
Reply With Quote
Old 02-04-2007, 04:25 PM
  #3
125cchyperman
 
Join Date: Mar 2006
Location: Manheim , PA
Posts: 2,599
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Truck not going even at full throttle???

Yes make sure that the slipper is nice and tight also make sure if you have a ball diff that the diff screw is nice and tight also. If the diff screw is loose that will also caus this.
125cchyperman is offline  
Reply With Quote
Old 02-04-2007, 04:34 PM
  #4
jdeadman
 
jdeadman's Avatar
 
Join Date: Feb 2006
Location: Thunder Bay, ON, CANADA
Posts: 170
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Truck not going even at full throttle???

Sounds like the throttle linkage is set improperly. Make sure that when you pull down on the trigger that the carb opens fully. If it does open fully then you may have it set way to rich

Try that first
jdeadman is offline  
Reply With Quote
Old 02-04-2007, 05:13 PM
  #5
littlebone
 
Join Date: Oct 2006
Location: willowgrove, PA
Posts: 34
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Truck not going even at full throttle???

u should check your slipper heres a good website for http://www.misbehavin-rc.com/pit-lan...adjustment.asp this can also help with other problems
littlebone is offline  
Reply With Quote
Old 02-04-2007, 05:22 PM
  #6
CJ3B
 
Join Date: Jan 2005
Location: Guaynabo
Posts: 41
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Truck not going even at full throttle???

I concur with the slipper clutch adjustment issue...
CJ3B is offline  
Reply With Quote
Old 02-04-2007, 05:39 PM
  #7
46u
 
46u's Avatar
 
Join Date: Jan 2005
Location: Macon, GA
Posts: 22,095
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Truck not going even at full throttle???

More information would help like what truck and like some others asked when giving it throttle where does the turning stop? Yes could be the slipper or the clutch or a bad differential or strip gear in the transmission or a screw missing in a drive cup and so on. Yes the slipper is the frist thing to check.
46u is offline  
Reply With Quote
Old 02-04-2007, 11:00 PM
  #8
bte214
 
bte214's Avatar
 
Join Date: Nov 2004
Location: Muskego, WI
Posts: 704
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Truck not going even at full throttle???

It's a XXX-NT. Set the slipper. Tighen all the way then back of 1/4 to a 1/2 turn. Then tighten the differential. All the way tight then 1/8 out. My guess would be the diff.
bte214 is offline  
Reply With Quote
Old 03-11-2007, 03:23 PM
  #9
kneeno
Thread Starter
 
Join Date: Jan 2007
Location: watertown, WI
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Truck not going even at full throttle???

I tightened the slipper all the way, and attempted to find the differential screw to tighten it as suggested. However, the manual shows the screw with the drive shaft apart and I'm having a hard time finding the screw to check it. Any suggestions? Thanks!
kneeno is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:56 PM.