RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

hitec 2.4 module for JR 10X

Reply

Old 05-20-2011, 06:32 PM
  #1  
DrYankum
Thread Starter
My Feedback: (11)
 
Join Date: Sep 2002
Location: Park Ridge, NJ
Posts: 163
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default hitec 2.4 module for JR 10X

I got a Hitec spectra 2.4 module to convert in my JR 10X. I've installed a 6 channel Optima receiver in a Fliton Jesky Extra 330 as a test bed for 2.4. I've been on the 6 meter ham band for 20 years but some of the events I go to now require 2.4 only. At any rate, when I power on the transmitter with the 2.4 module in place, only 1 of the 2 pilots lights on the Tx light up. It does this on both my 10Xs. A google search failed to give me any info as to whether this is a normal conditon for this module. I haven't range checked yet, but even if the range is correct I'm still reluctant to put the model at risk. On the bench the link is solid and everything seems to work properly. Any one have any insight on this?
DrYankum is offline  
Reply With Quote
Old 05-20-2011, 06:37 PM
  #2  
A.T.
Senior Member
 
Join Date: Jul 2002
Location: Auckland, NEW ZEALAND
Posts: 2,581
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: hitec 2.4 module for JR 10X


ORIGINAL: DrYankum I got a Hitec spectra 2.4 module to convert in my JR 10X. I've installed a 6 channel Optima receiver in a Fliton Jesky Extra 330 as a test bed for 2.4. I've been on the 6 meter ham band for 20 years but some of the events I go to now require 2.4 only. At any rate, when I power on the transmitter with the 2.4 module in place, only 1 of the 2 pilots lights on the Tx light up. It does this on both my 10Xs. A google search failed to give me any info as to whether this is a normal conditon for this module. I haven't range checked yet, but even if the range is correct I'm still reluctant to put the model at risk. On the bench the link is solid and everything seems to work properly. Any one have any insight on this?
No 10TX immediately available to check,but suspect it is the same as Futaba 9C etc.
One LED will not light because it usually lights to confirm PPMRF output is activefrom standard antenna.
2.4GHz does not emit via the standard antenna so the TXPPMRFactive light will not light up,the AFHSSmodule emits red/blue light in lieu thereof.

A little later:
JR-10X:
"That is correct, The LED on the right indicates RF and is a true indication that RF is being generated. ie Detected, rectified and used to drive the LED. If you use a 3rd party plug in module for 2.4 GHz, the LED will remain dark. "


more under: Hitec Support Fourm Sticky:
Aurora 9, Spectra 2.4GHz Module & Optima Transceivers - FAQ & Undocumented Features
- Mixes, Setups, Tips. {Individual Links often updated}

Alan T.
Alan's Hobby, Model & RC FAQ Web Links
A.T. is offline  
Reply With Quote
Old 05-20-2011, 06:50 PM
  #3  
DrYankum
Thread Starter
My Feedback: (11)
 
Join Date: Sep 2002
Location: Park Ridge, NJ
Posts: 163
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: hitec 2.4 module for JR 10X

Thanks Alan....seems reasonable.
Jerry
DrYankum is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service