RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

2s lipo unregulated on the RX, anyone running this?

Reply

Old 09-11-2012, 05:37 PM
  #1  
JohnVH
Thread Starter
My Feedback: (38)
 
JohnVH's Avatar
 
Join Date: Dec 2001
Location: Ferndale, WA
Posts: 16,108
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default 2s lipo unregulated on the RX, anyone running this?

I have a bird I bought that came this way, and Ive flown it 10 times now and it works great, and the previous owner has run it a long time like this, but I cant stop thinking about the power getting to the servo's, I know the RX can handle it, but how long with the servo's?

Looking for people that have run this setup to chime in.

Thanks!
JohnVH is offline  
Reply With Quote
Old 09-11-2012, 05:49 PM
  #2  
BuschBarber
Senior Member
My Feedback: (2)
 
Join Date: Jan 2002
Location: Rochester, NY
Posts: 4,756
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 2s lipo unregulated on the RX, anyone running this?


ORIGINAL: JohnVH

I have a bird I bought that came this way, and Ive flown it 10 times now and it works great, and the previous owner has run it a long time like this, but I cant stop thinking about the power getting to the servo's, I know the RX can handle it, but how long with the servo's?

Looking for people that have run this setup to chime in.

Thanks!
2cell LiPos charge to 8.4v. Only HV servos can handle that voltage without regulators. If you use 2cell LiFe batteries, you can use them, unregulated, with any servo compatible with 6v.
BuschBarber is offline  
Reply With Quote
Old 09-11-2012, 07:16 PM
  #3  
snuts
Senior Member
 
Join Date: Dec 2008
Location: camrose alberta, AB, CANADA
Posts: 514
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 2s lipo unregulated on the RX, anyone running this?

John, what servos?
With the information given so far, yes.
I too have bought a used airframe. Running 2S Li-Po unregulated. Now with 29 flights of my own. Hitec HS7954 (5), HS7950 (1).
-Snuts-
Attached Thumbnails Click image for larger version

Name:	Ca80442.jpg
Views:	14
Size:	992.1 KB
ID:	1800352  
snuts is offline  
Reply With Quote
Old 09-11-2012, 08:21 PM
  #4  
countilaw
 
countilaw's Avatar
 
Join Date: Jan 2012
Location: Grand Prairie, TX
Posts: 1,300
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 2s lipo unregulated on the RX, anyone running this?

Are you sure your ESC doesn't have a built in BEC? You didn't say what kind of plane you had. Most of the cheap foamies have them.

Frank
countilaw is offline  
Reply With Quote
Old 09-11-2012, 09:02 PM
  #5  
JohnVH
Thread Starter
My Feedback: (38)
 
JohnVH's Avatar
 
Join Date: Dec 2001
Location: Ferndale, WA
Posts: 16,108
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 2s lipo unregulated on the RX, anyone running this?

were talking about a 71" slick, E powered, but no BEC, a 2 cell lipoly straight into the RX with tower hobbies servos ( I know.... ) digital TS150's... tower servo's straight up suck, not gonna lie. But thats not the question at hand.
JohnVH is offline  
Reply With Quote
Old 09-12-2012, 10:18 AM
  #6  
snuts
Senior Member
 
Join Date: Dec 2008
Location: camrose alberta, AB, CANADA
Posts: 514
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 2s lipo unregulated on the RX, anyone running this?

SPECS: 4.8V 6.0V
Speed: 0.26 sec @ 60° 0.21 sec @ 60°
Torque: 162 oz-in (11.7 kg/cm) 193 oz-in (14 kg/cm)
Length: 1.6" (41mm)
Width: 0.8" (20mm)
Height: 1.5" (38mm)
Weight: 1.9oz (53g)
Connector: Universal
Spline- 25

From the Tower web site.
They may be working (outside of design), but expect a failure on only one at a time. A regulator would be advisable. Over voltage is very hazardous, electronics do NOT like this condition.

Hope this helps,
-Snuts-

snuts is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service