RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Lemon Rx issue

Reply

Old 04-23-2018, 09:47 AM
  #1  
jkisinger
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Lemon Rx issue

I have a very strange problem. I was getting a plane ready to go to the flight field and I turned it on and had no led on the receiver. I checked the battery and it had 5.3v. I checked all connections. I plugged the battery directly to the receiver and no power. I pulled another receiver from another plane. I plugged the battery in and it was fine. I ran it through the switch and lost power. Now that receiver also will not power on even by plugging the battery in direct. Did the switch somehow mess up these receivers. I've used these receivers with success and no issues until now. Any thoughts?
jkisinger is offline  
Reply With Quote
Old 04-23-2018, 10:29 AM
  #2  
BarracudaHockey
My Feedback: (11)
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 23,311
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

My initial thought is for the cost, try another, if the rx is the issue throw it in the trash.

Plugging them in wrong doesn't or shouldn't burn them up.
BarracudaHockey is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service