RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

what ! JR retract servo, not turning 180

Reply

Old 08-01-2018, 10:07 AM
  #1  
the Wasp
Thread Starter
My Feedback: (1)
 
Join Date: Sep 2003
Location: VT
Posts: 3,533
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default what ! JR retract servo, not turning 180

Guys, like I say^, my brand new JR (791) retract servo is not turning 180, when I received it I tested it and it turned 180, but now it's not,, it's only turning about 145 degrees, (checked with my protractor)

I have adjusted my TX, but these retract servos should are not adjustable at the TX,, it has never been hooked up to the linkage !

my TX is the XG8,, what could be the problem ??

thanks guys !!

Jim
the Wasp is offline  
Reply With Quote
Old 08-01-2018, 08:50 PM
  #2  
mark20
 
Join Date: Dec 2017
Posts: 17
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

have you tried a different channel? that could be your issue. also try setting your limits all the way to the left, then check to see if it went away. if it didnt do anything try all the way to the right. also all servos should be ajustible. make sure you have a full battery (both tx and rx).

if all the above doesn't work. than i suspect some of the internal gears are stripped.
you could contact warranty and ask for a replacement, it may be a defected product.

hope this helps
mark20 is offline  
Reply With Quote
Old 08-01-2018, 08:59 PM
  #3  
the Wasp
Thread Starter
My Feedback: (1)
 
Join Date: Sep 2003
Location: VT
Posts: 3,533
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

thanks for the reply, but this is a retract servo, it's not adjustable at the TX, you flip the switch and it will travel to it's maximum travel, even if you test it on the ruder channel it will only travel to its fullest, it has only one speed, it doesn't go faster and it doesn't go slower, I did check it on another channel and it moved the same,, it has metal gears and they are OK

I am starting to think there is nothing wrong with it, and it is supposed to only move as much as it does

Jim
the Wasp is offline  
Reply With Quote
Old 08-02-2018, 04:20 AM
  #4  
BarracudaHockey
My Feedback: (11)
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 23,306
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Originally Posted by mark20 View Post
have you tried a different channel? that could be your issue. also try setting your limits all the way to the left, then check to see if it went away. if it didnt do anything try all the way to the right. also all servos should be ajustible. make sure you have a full battery (both tx and rx).

if all the above doesn't work. than i suspect some of the internal gears are stripped.
you could contact warranty and ask for a replacement, it may be a defected product.

hope this helps
Nope, retract servos swing 180 degrees and shut off. The retracts should lock if they are setup right and there's no need to drain the battery while holding the gear up or down.

They don't take end point or speed settings from the radio, they see the sweep change when you flip the retract switch, do their thing, then shut off, they aren't proportional.
BarracudaHockey is offline  
Reply With Quote
Old 08-02-2018, 06:49 AM
  #5  
mark20
 
Join Date: Dec 2017
Posts: 17
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Originally Posted by BarracudaHockey View Post
Nope, retract servos swing 180 degrees and shut off. The retracts should lock if they are setup right and there's no need to drain the battery while holding the gear up or down.

They don't take end point or speed settings from the radio, they see the sweep change when you flip the retract switch, do their thing, then shut off, they aren't proportional.
I see, thanks for informing me.
mark20 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service