RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

transmitter doesn't work a fter store

Reply

Old 05-02-2019, 02:09 AM
  #1  
lazezo
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Unhappy transmitter doesn't work a fter store

hi all
i have an cheap RC plane
shangfei-toys sf556 3.5 CHANNEL R/C HELICOPTER WITH GYRO AND LIGHT
it was working well before i stored it!!
i follow the instruction of store
remove transmitter battery and disconnect plane battery
and cover it well from dust!

now after charge it and using new remote control battery
it wont work
the problem is the led of transmitter is flashing
to start operation the throttle stick must move up then down so transmitter led stop flashing and that mean i can start the plane
i guess the transmitter before start operation need to check full function of throttle !!.
am i right??
at the same time i can turn on and off plane light using transmitter light button!
that mean transmitter and reciever are ok right?

so is the problem in throttle control stick?
i open the transmitter and try to measure the resistant of throttle but
it's 1 k ohm and doesn't change with moving the stick!
i try to measure the 2 axis throttle (acc/decc and left/right) but it is the same, fixed 1 k ohm !!
do i have to disconnect the throttle for correct measure?

it was working before store so what happen?
is it the dust? even it was covered well!and no dust inside transmitter!!
can i disconnect the throttle and open it and clean internal parts???
and if so is there any instruction?

any help?
thanks
lazezo is offline  
Reply With Quote
Old 05-08-2019, 09:13 AM
  #2  
lazezo
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

any help?
lazezo is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service