RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

servo humming???

Reply

Old 09-28-2003, 05:03 AM
  #1  
flyfree69
Senior Member
Thread Starter
 
Join Date: Jan 2003
Location: DES-MOINES, IA
Posts: 130
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default servo humming???

i installed the servos in my mustang and one of them is humming, i cant tell which one it is , they are jr-537's is that a problem? what about battery drain? it only starts humming when i turn the tx on. i can't see any binding, none of my other planes do this. any ideas? thanks for any help Larry
flyfree69 is offline  
Reply With Quote
Old 09-28-2003, 11:04 AM
  #2  
Rodney
Senior Member
 
Join Date: Dec 2001
Location: FL
Posts: 7,769
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: servo humming???

You are probably okay but to be sure, can you monitor the current being drained from you receiver battery? If it is within reason (probably about 10 ma. per servo with no command ) you should be okay. I'm not familiar with that particular servo but; if it is the throttle servo and you are trying to run it up against one end or the other, this could be bad as it will cause excessive current drain while in that position. Also, if these are coreless servos and the one on the elevator is doing the buzzing and you have very frictionless pushrods, the fact that gravity trys to droop the surface and the servo trys to pick it back up will cause some buzzing. Another possibe cause would be excessively high friction in one of the surfaces. Can you disconnect one servo at time and find out which one is buzzing? If you make a slight movement of one of the control sticks does the buzzing stop or change in amplitude or frequency?
Rodney is offline  
Reply With Quote
Old 09-29-2003, 07:28 PM
  #3  
flyfree69
Senior Member
Thread Starter
 
Join Date: Jan 2003
Location: DES-MOINES, IA
Posts: 130
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: servo humming???

i narrowed it down to the throttle servo, i disconnected the servo horn and it still keeps humming. could the servo be bad? it works just fine. it only starts humming when i turn my radio on. i have a voltwatch on the plane could that be doing something to it? thanks for the help Larry[]
flyfree69 is offline  
Reply With Quote
Old 09-30-2003, 09:13 AM
  #4  
Rodney
Senior Member
 
Join Date: Dec 2001
Location: FL
Posts: 7,769
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: servo humming???

Now that you have narrowed it down to the throttle (often the most difficult servo to hook up without excessive friction in the process of going around the fuel tank) are you sure there is not excessive friction? Can you grasp the end of the pushrod at the servo end (with it disconnected from the servo) and easily move the throttle? If not, you need to rework the throttle pushrod. If this is free moving then you may have a bad servo, swap it with another and see if that problem changes position.
Rodney is offline  
Reply With Quote
Old 09-30-2003, 09:18 AM
  #5  
bearmech
Senior Member
My Feedback: (1)
 
Join Date: Feb 2003
Location: Rockwall, TX
Posts: 522
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: servo humming???

JR 537s tend to buzz around the center anyway, especially with a fresh charged battery. However do check your throttle linkage just to be sure!
bearmech is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service