RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

need help with Dxe

Reply

Old 09-08-2019, 01:46 PM
  #1  
z-rc135
Junior Member
Thread Starter
 
Join Date: Aug 2019
Posts: 16
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default need help with Dxe

My dxe transmitter will not bind to any rx, (even ones it has been bound to before) and whenever I turn it on, the leds flash for a second or two then go solid and at the same time gives two descending tones. then gives a tone that is repeated every second. also when it is buddy boxed with the dxe being the slave and another tx being the master the dxe only has right aileron, and pretty much no left same with rudder and elevator. whereas the master has full throw on all control surfaces.
z-rc135 is offline  
Reply With Quote
Old 09-08-2019, 06:04 PM
  #2  
MaxSouthoz
 
Join Date: Oct 2017
Location: South Australia
Posts: 130
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I had a similar issue. I replaced the batteries and it recovered.

I hope yours might be the same.

Cheers
Max
MaxSouthoz is offline  
Reply With Quote
Old 09-09-2019, 07:33 AM
  #3  
z-rc135
Junior Member
Thread Starter
 
Join Date: Aug 2019
Posts: 16
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Just tried replacing batteries, no improvement.
z-rc135 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service