RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Airtronics Synthesized Transmitter Problem

Reply

Old 09-15-2004, 11:23 PM
  #1  
skippystahl
Junior Member
Thread Starter
 
Join Date: Sep 2004
Location: Cincinnati, OH
Posts: 12
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Airtronics Synthesized Transmitter Problem

I have recently purchased an Airtronics MX3S Synthesized Transmitter and an Airtronics 92836 receiver. The receiver is not synthesized. I installed the crystals in the receiver and set the transmitter to the same frequency. Both are 75mhz. I purchased Airtronics servos as well and have two of them installed. The other servo is a Futaba style which I used a JR connector to make work. When I power up the receiver I can hear the servos twitch and the failsafe lights up and flashes. When I turn the transmitter on nothing happens. The failsafe continues to flash indicating that either the receiver batteries are dead, the transmitter batteries are dead, or that somehow the receiver is not recognizing the transmitter. I have checked all of the batteries and they are fine. I have double checked that the frequency of the transmitter matches the crystal. I have no idea why nothing works. I have even removed the failsafe and still nothing. For some reason or other the receiver is not recognizing the transmitter. If I have the synthesized transmitter do I have to have the synthesized receiver. If anyone has any input or recommendations I would love to hear them. Thanks.
skippystahl is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service