RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

I think I am ok but would like your input to be sure

Reply

Old 01-12-2005, 10:25 PM
  #1  
Flyguy5
Junior Member
Thread Starter
 
Join Date: Jan 2005
Location: , CT
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default I think I am ok but would like your input to be sure

I Have a JR 770s rx powerflight rx battery and regulator. I was working on my plane and I turned the rx switch on and got no response from my servos looked around for a problem tried again no luck I then turned the switch off followed the wires and found that I hooked the battery up backward to the wire that goes to the switch I then hooked the battery up the right way to the switch wire and everything worked fine. I did not notice heat or any smoke or smoke smell. I just want to make sure I am ok before I use this setup. I am guessing that either the regulator or switch protected the rx but wanted to ask to be sure.

Best,
Rob
Flyguy5 is offline  
Reply With Quote
Old 01-13-2005, 12:46 AM
  #2  
mglavin
My Feedback: (31)
 
Join Date: Nov 2001
Location: Elverta, CA
Posts: 5,295
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: I think I am ok but would like your input to be sure

More likely than not, NO damage was caused. The control signal wire is typically dead-headed in the switch or non-existent in the plug or on the switch lead. In any event you're only able to mis-configure the batteries common or negative wire. The center wire is the positive wire, while the outboard wires are the battery negative or servo control signal. I believe all of the current radio offerings follow this wiring scheme. OLD Airtronics is another story.
Attached Thumbnails Click image for larger version

Name:	Mk24887.gif
Views:	4
Size:	7.0 KB
ID:	214446  
mglavin is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service