RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

RECIEVER BAD OR WHAT?

Reply

Old 07-23-2005, 05:05 PM
  #1  
TommyAZ
Junior Member
Thread Starter
 
Join Date: May 2005
Location: Glendale, AZ
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RECIEVER BAD OR WHAT?

I HAVE GOTTEN A NEW SPEED CONTROL BOARD AND REPLACED THE BATTERY. THE SERVOS
AND ALL THE CHANNELS SEEM TO WORK FIND. I CAN NOT GET MY SPEED CONTROL BOARD
TO RESET, SO THE MOTORS WILL START. lITTLE ELEC. HELICOPTER. TRIED EVERYTHING
CAN THE RECIEVER BE BAD? EVERYTHING, ALL THE SERVOS AND MOTORS WORK. HELP ME OUT, IF YOU CAN. THANKS TOMMY AZ
TommyAZ is offline  
Reply With Quote
Old 07-25-2005, 08:03 AM
  #2  
ljhmc
Senior Member
 
Join Date: Aug 2004
Location: Omaha, NE
Posts: 108
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: RECIEVER BAD OR WHAT?

Not sure if I can help but, I have been having trouble with my radio and Ducted fans for a while. At least I thought. Try this, disconnect the batteries from the speed control, trun off your transmitter, conect your batteries back to your speed control, turn it all on, then turn on your transmitter.

Let me know, good luck.

Lawrence
Omaha, Nebraska
ljhmc is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service