RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

***Airtronics blazer radio problems***

Reply

Old 11-22-2002, 10:09 PM
  #1  
jdavid2002
Junior Member
Thread Starter
 
Join Date: Nov 2002
Location: Waco, TX
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default ***Airtronics blazer radio problems***

Okay guys,
Here is my problem. I just bought a new Airtronics Blazer system. It came with a airtronics 2 channel reciever and a standard servo. I already have the identical reciver in my truck (RC10 T3). I have a Novak Explorer II ESC and a standard airtronics servo in my truck. I went to program the ESC and it won't respond to the radio. I was told that I would have to put "Z" connectors on my ESC to plug into the reciever. I was then told that it doesn't matter what kind of connectors you have as long as the polarity is right. I have been to the Airtrinucs website to take a look at the "Z" connectors and it showed the black and red wires to be crossed on the . I've done that but it still does not work. But, my radio batts and my truck batt are pretty low on juice. Are these theories right, are they wrong or do they even apply? I have tested all my other equipment out on another reciver and radio ( a very old futaba radio and reciver) and it all works. Below I have attached the website that I went to at Airtronics. Thank guys!

http://www.airtronics.net/picture_shows_the_pin.htm
jdavid2002 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service