RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

aitronics to airtronics Z, failed?

Reply

Old 08-15-2006, 01:22 PM
  #1  
squirrel1620
Junior Member
Thread Starter
 
Join Date: Jul 2006
Location: , CO
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default aitronics to airtronics Z, failed?

hi, i have 2 JR servos connected to a JR Y-harness for the ailerons and and older style airtronics receiver (92765/72).
i have the y-harness connected to the rx with a Airtronics - airtronics Z wire which switches the black and red wires to be compatible with JR/futaba/hi tech
but for some reason the ailerons still wont function. any ideas?
squirrel1620 is offline  
Reply With Quote
Old 08-15-2006, 02:58 PM
  #2  
pilotpete2
 
pilotpete2's Avatar
 
Join Date: Oct 2002
Location: Lyndonville, VT
Posts: 3,298
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: aitronics to airtronics Z, failed?

One possibility is that the adaptor harness is bad, also check to see that the plug from the Y harness to the airtronics adaptor is not plugged in backwards, yes universal style plugs will go in 180dg out surprisingly easily in many cases, their keying is not all that positive.
I too have all old style Airtroncs RX that I use them with a mix of new and old servos, all my new universal style servos, ESCs and switch harnesses have the pos and neg wires reversed and they are plugged directly into the Rx, been doing it for some years and I haven't smoked one YET (I sooo will regret saying that.) I mention this way of dealing with the issue while it has risks while hooking up a system, it does result in greater reliability by eliminating extra connectors. Good luck.
Pete
pilotpete2 is offline  
Reply With Quote
Old 08-15-2006, 05:05 PM
  #3  
carrellh
Senior Member
 
carrellh's Avatar
 
Join Date: Mar 2003
Location: Garland, TX
Posts: 6,544
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: aitronics to airtronics Z, failed?

There are lots of variables.
Receiver
Adapter
Y Harness
2 servos

Any or all of them could be the problem

I’d eliminate the receiver possibility first by plugging a servo, that works in this receiver, into the aileron channel.

RCKen posted a picture that shows the different wiring. It also has info about moving the wires in the connectors so you don’t need adapters.

If the receiver checks out, I’d eliminate the adapter from the list of possibilities. Move the wires in the “Y” harness connector to match the receiver and give it a try. You may or may not need to shave the plastic connector to get it plugged into the receiver.

If it doesn’t work, move the wires in the servo connectors and plug them directly into the receiver. If they both work, the problem is the “Y”
Attached Thumbnails Click image for larger version

Name:	Ki18190.jpg
Views:	6
Size:	183.6 KB
ID:	507853  
carrellh is offline  
Reply With Quote
Old 08-15-2006, 10:18 PM
  #4  
squirrel1620
Junior Member
Thread Starter
 
Join Date: Jul 2006
Location: , CO
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: aitronics to airtronics Z, failed?

thanks for the help guys but ive found my problem, it appears that when you connect a "Z" connector servo into a non Z RX, it fries the servo so i bought 2 new Futaba servos and hooked it up with the converter and problem solved! time for the maiden flight
squirrel1620 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service