RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

servos twitching????/??

Reply

Old 08-20-2006, 08:30 PM
  #1  
nickdavis
Junior Member
Thread Starter
 
Join Date: Aug 2006
Location: lemoore, CA
Posts: 20
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default servos twitching????/??

ok so i have all my servos hooked up and when i turn on the switch things do as normal but after a few moments of sitting then the servos start twiching? what causes this ? did i hook up some thing wrong? is this a major problem or is it normal?
nickdavis is offline  
Reply With Quote
Old 08-20-2006, 09:03 PM
  #2  
Pile-O-Wood
Senior Member
 
Join Date: Dec 2002
Location: Third Rock From the Sun,
Posts: 184
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: servos twitching????/??

If your xmitter is on you have a problem. If it is off, this is normal.
Pile-O-Wood is offline  
Reply With Quote
Old 08-21-2006, 03:15 PM
  #3  
billz
Member
 
billz's Avatar
 
Join Date: Apr 2005
Location: Eagan, MN
Posts: 84
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: servos twitching????/??

Nick,

This could be "normal" for lower quality, no-name servos. I purchased a Park Zone Typhoon and noticed the servos twitching under normal conditions. When I switched them out for some name brand HITEC servos, the twitching stopped competely. I made no other change. I don't know why that would be however.

Bill
billz is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service