RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Sullivan smoke pump glitching - help

Reply

Old 08-21-2006, 08:54 AM
  #1  
kenair
Thread Starter
My Feedback: (10)
 
kenair's Avatar
 
Join Date: Jan 2002
Location: winnipeg, MB, CANADA
Posts: 860
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Sullivan smoke pump glitching - help

HI, a buddy and I both bought the Sullivan Skywriter smoke pumps this spring. [link=http://www.sullivanproducts.com/FuelPumpsMainFrame.htm]Sullivan web site[/link].
Sullivan says the pumps are able to handle 6 to 12V.


He is using a 2 cell lipoly pack at 7.4 volts - he is using a JR 649pcm rx and is getting glitches when he turns on the smoke pump in flight.

I first used a 7 cell nicad AA pack (8.4) volts and got terrrible glitching on the ground - then the motor burned out - sent back to Sullivan for warranty work.
Tried again using a 4 cell nicad pack - worked ok, but it seemed the pump need more power to push the fluid out, flew with no glitches with a 4 cell nicad pack.

This weekend I tried the 7 cell pack - but got the glitches again. I am using JR pcm 910rx.

Any one have simliar experiences. thanks in advance.
-ken
kenair is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service