RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Royal EVO V-Tail Mixer

Reply

Old 06-27-2007, 06:52 AM
  #1  
SBarber
Junior Member
Thread Starter
 
Join Date: Jan 2003
Location: Grant, FL
Posts: 24
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Royal EVO V-Tail Mixer

I seek help from the EVO gurus.

I have just set up my V-tail sailplane on the EVO 9. The first problem encountered was the rudder was reversed. The manual says to correct this in the V-tail mixer so I reversed the rudder in the mixer, changed 100% to -100%. The rudder now works correctly when the transmitter is activated but it caused a different problem. If I monitor the servos, the rudder show both servos working together and the elevator shows the servos going opposite directions. When elevator is added to any of the mixers, it activates the rudder instead of the elevator. I've tried reversing the servos and that doesn't help.

How can I get the elevator and rudder working correctly?

Thanks in advance for your help.

Steve
SBarber is offline  
Reply With Quote
Old 06-27-2007, 09:47 AM
  #2  
SBarber
Junior Member
Thread Starter
 
Join Date: Jan 2003
Location: Grant, FL
Posts: 24
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Royal EVO V-Tail Mixer

OK, I got the transmitter portion straightened out by just reversing one of the tail servos. The rudder direction is still wrong though and reversing the mixer doesn't help. Any suggestions?

Steve
SBarber is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service