RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

2 week old Hitec programmer wont work!!

Reply

Old 07-07-2007, 09:34 PM
  #1  
Zman39
Thread Starter
My Feedback: (6)
 
Zman39's Avatar
 
Join Date: Jan 2005
Location: Central, FL
Posts: 582
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default 2 week old Hitec programmer wont work!!

I purchased a Hitec HFP-10 2 weeks ago and used it once with success. I pulled it out tonite to center a servo and it wont turn on. Voltage check shows good, but no display. Any ideas?

Thanks

Z
Zman39 is offline  
Reply With Quote
Old 07-07-2007, 10:11 PM
  #2  
tail strike
My Feedback: (1)
 
tail strike's Avatar
 
Join Date: May 2003
Location: North Las VegasNV
Posts: 789
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 2 week old Hitec programmer wont work!!

Did you format the battery in the programer? Mine has a 1100MA battery you should charge a new battery for 16 to 24 hr. at 1c or 110ma
tail strike is offline  
Reply With Quote
Old 07-08-2007, 04:17 AM
  #3  
Zman39
Thread Starter
My Feedback: (6)
 
Zman39's Avatar
 
Join Date: Jan 2005
Location: Central, FL
Posts: 582
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 2 week old Hitec programmer wont work!!

Yes, I did that when I first got it and afterwards I used it on two servos and it worked great. Pulled it out last night for another plane I am working on and nothing; but voltage shows good.

Z
Zman39 is offline  
Reply With Quote
Old 07-08-2007, 01:09 PM
  #4  
tail strike
My Feedback: (1)
 
tail strike's Avatar
 
Join Date: May 2003
Location: North Las VegasNV
Posts: 789
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 2 week old Hitec programmer wont work!!

Hmmmmm I don no whats going on[]
tail strike is offline  
Reply With Quote
Old 07-08-2007, 06:13 PM
  #5  
dragoonpvw
Senior Member
My Feedback: (7)
 
Join Date: Apr 2002
Location: Mount Dora, FL
Posts: 877
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 2 week old Hitec programmer wont work!!

If you haven't charged it in two weeks you will need to do it again. If I leave mine for that long I may get a screen when I first switch it on but it will cut off pretty quick after that. The charge lasts a few days but not for long. The annoying with the programmer is that it draws a current even when the unit is switched off, I don't know why but it does. Check old posts on the hitec forum. Just make sure you give it a good charge before you use it. When it has a new battery in it it lasts a bit better, mine is now a few years old and it is terrible. I just charge it immediately before I use it now.
Good Luck
Paul
dragoonpvw is offline  
Reply With Quote
Old 07-08-2007, 06:45 PM
  #6  
Zman39
Thread Starter
My Feedback: (6)
 
Zman39's Avatar
 
Join Date: Jan 2005
Location: Central, FL
Posts: 582
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: 2 week old Hitec programmer wont work!!

Thanks all,

I tried that and several other things today with zero luck. I guess it took a dump. Looks like I will have to send it in.[]

Z
Zman39 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service