RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Single channel glitching

Reply

Old 03-02-2008, 12:27 AM
  #1  
broke_n_bummin
Senior Member
Thread Starter
 
broke_n_bummin's Avatar
 
Join Date: Mar 2006
Location: Kershaw, SC
Posts: 838
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Single channel glitching

I'm not really a NooB (been in to RC flying for about 15 years) but I am constantly learning new things. I have a Futaba FM RX that has me scratching my head. I've had glitching problems before, but not quite like this. This RX only glitches on channel 6 (flaps). I've never had one do that before. I've changed the servo (single servo flaps), extention, rerouted the wiring and even used a nyrod for the throttle (it passes near the servo). I even went so far as to connect another servo to it that wasn't attatched to the plane, and it still does it. It's spurratic, and it's the only channel and the only rx that does it. The RX is about 3 years old, and is on Ch 42. I bought it new and the oscillator has never even been removed. I had it in a U Can Do about 6 months ago and never had a problem with it (using flapperons). Is it about time to give it a proper burrial or is there a simple fix that I haven't thought of?
broke_n_bummin is offline  
Reply With Quote
Old 03-02-2008, 12:32 AM
  #2  
broke_n_bummin
Senior Member
Thread Starter
 
broke_n_bummin's Avatar
 
Join Date: Mar 2006
Location: Kershaw, SC
Posts: 838
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Single channel glitching

I forgot to mention that I replaced the antenna, it's never been crashed and never gotten wet.
broke_n_bummin is offline  
Reply With Quote
Old 03-02-2008, 04:12 AM
  #3  
jooNorway
Senior Member
 
Join Date: Dec 2004
Location: Naersnes, NORWAY
Posts: 912
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Single channel glitching

Could be the receiver, but it could also be the potmeter on your flaps-channel at your transmitter...
jooNorway is offline  
Reply With Quote
Old 03-02-2008, 01:12 PM
  #4  
Deadeye
Senior Member
 
Deadeye's Avatar
 
Join Date: Jul 2002
Location: Dutton, MT
Posts: 4,516
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Single channel glitching

There is only one logical step left. You must swap out the RX and see if the problem persists.
Deadeye is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service