RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Hitec crystal

Reply

Old 03-11-2002, 05:35 AM
  #1  
Mrsamman
Member
Thread Starter
My Feedback: (2)
 
Join Date: Jan 2002
Location: Tulsa, OK
Posts: 82
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Hitec crystal

I have a used hitec focus four TX. and a 7 channel dual conversion Rx. The Tx is on channel 42 and I am assuming the Rx is also. The problem the numbers on the crystals don't match up. I want to either echange them are just outright buy new ones. Where do I buy them and what am I asking for?
I assume Futaba crystals work with no problem, and if I wanted to could I get a different channel if it was still in the fourtys.
Thanks
Scott
Mrsamman is offline  
Reply With Quote
Old 03-11-2002, 06:27 AM
  #2  
flatfour
Senior Member
My Feedback: (8)
 
Join Date: Dec 2001
Location: Midlothian, IL
Posts: 597
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Hitec crystal

If you are talking about the frequency not matching that is somewhat normal. Some crystals are marked with the actual freq on the metal case. You have to take into account the intermediate frequency of 10.7MHz.

If this setup was working, you can be sure that the crystals match
flatfour is offline  
Reply With Quote
Old 03-12-2002, 04:04 AM
  #3  
Mrsamman
Member
Thread Starter
My Feedback: (2)
 
Join Date: Jan 2002
Location: Tulsa, OK
Posts: 82
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Hitec crystal

I have never used the radio and I can't test it right now because the batteries are shot, I ordered new batteries. The printed numbers on the crystals don't make any sense and their aren't any frequency tags on the crystals themselves. I guess we'll see when the batteries get here.
Thanks
Scott
Mrsamman is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service