RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Dynamite Tazer 15T esc problems

Reply
Old 02-20-2009, 01:38 PM
  #1
idaho kid
Thread Starter
 
Join Date: Dec 2008
Location: Post Falls, ID
Posts: 25
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Dynamite Tazer 15T esc problems

Hi, I've got a new tazer 15t esc and it is not working. When I try to program it, it will not program. The red and green light do not come on for the first step of programming only the red light. I'm using a Traxxas 4 channel receiver and Traxxas radio. Need some help.
Thanks,
Gary
idaho kid is offline  
Reply With Quote
Old 02-28-2009, 03:53 PM
  #2
GoDonkeys
 
Join Date: Feb 2009
Location: Ridgecrest, CA
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Dynamite Tazer 15T esc problems

Not that it's much help, but I've got two of these and a friend has one as well. My friend's and my first one took awhile before finally going into program mode.

In my friend's case, we tried for about an hour trying various transmitters and battery packs before finally giving up. A couple of hours later we decided to give it one more try and it worked.

With my other one, I went through a similar process before it finally worked.

I'm currently trying to get one setup for my son and have about given up on it. I've written to the support desk and am waiting to hear back.

Like I said at the beginning, it's not much help, but in the first two cases, persistence and continually trying every possible combination (including unplugging the battery pack) and it finally worked. It is such a shame because of the value these ESCs provide. Tough to beat for the money once you get them to program.
GoDonkeys is offline  
Reply With Quote
Old 02-28-2009, 05:01 PM
  #3
A.T.
 
Join Date: Jul 2002
Location: Auckland, NEW ZEALAND
Posts: 2,581
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Dynamite Tazer 15T esc problems


Quote:
ORIGINAL: idaho kid Hi, I've got a new tazer 15t esc and it is not working. When I try to program it, it will not program. The red and green light do not come on for the first step of programming only the red light. I'm using a Traxxas 4 channel receiver and Traxxas radio. Need some help. Thanks, Gary
1. Check Throttle trim switch is below mid position, preferably low.
2. Check throttle reversing switch is in correct positon.
3. Battery pack fully charged? recharge anyway before next attempt.
4. Refer to sub section "Glitches & Jitter in Receiver, Servo & ESC - causes and cures" especially
E.P.A - A.T.V - Dual Rates differences, cautions and arming ESC
at
Alan's Hobby, Model & RC FAQ Web Links
Regards
Alan T.
A.T. is offline  
Reply With Quote
Old 02-28-2009, 05:15 PM
  #4
GoDonkeys
 
Join Date: Feb 2009
Location: Ridgecrest, CA
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Dynamite Tazer 15T esc problems

I looked into it some more and found someone at Radio Control Zone.com that had the same problem. Turns out he had the plug from the ESC to the receiver was in reversed. I swapped mine around and it right to the program mode!

Don't know if you've tried this, but it worked for me!
GoDonkeys is offline  
Reply With Quote
Old 12-26-2012, 02:54 PM
  #5
TheHyrax
 
Join Date: Dec 2012
Location: , FL
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Dynamite Tazer 15T esc problems

Hi.. I just got into this hobby so I'm a Noob.. I'm trying to program (if possible) the Tazer 15t by Dynamite. Model DYN4925WP. If possible I would like to remove the brake delay or the delay between forward and reverse. I'm trying to pop wheelies but the delay from reverse to forward is not allowing the torque to take place. Or maybe I'm doing something else wrong?..thanks
TheHyrax is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:14 PM.