RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

twitching servo help PLEASE

Reply

Old 03-28-2010, 06:14 PM
  #1  
trueimport
Thread Starter
My Feedback: (1)
 
Join Date: Aug 2008
Location: Lake Villa, IL
Posts: 90
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default twitching servo help PLEASE

I dont even know really how to explain this but I'll give it a shot and I'll make it short. I have one AM set and one FM set of RX and TX. On the FM I cant get it to do a damn thing other then when I first turn the power on I'll get the smallest amount of servo movement but no control of any kind. If I move the RX antenna wire around it makes the servos twitch like crazy. On the AM set the servos twitch out of control and barely any response to the steering servo and none on the throttle. If I move the TX closer it works a little better and when I move it about 3-4 feet away I get nothing. And on that same set if I only plug in the steering servo it works a little better but if I try it with the throttle only I cant get it to do anything. So in other words I cant control either of them no matter what I try.

Here's what I have.......
AM (TX) - Traxxas Top Qualifier 27mhz
AM (RX) - Traxxas Top Qualifier 27mhz 2215 x-tal
I use the above in an electric car with no issues

AM (RX) - JRracing R125 75mhz
I tried this with the Traxxas TX and get some movement

FM (RX) - Duratrax RX-301F 75mhz
FM (TX) - Duratrax 2 channel 75mhz (matching to above RX)
This was the stock equipment for the buggy and was working fine but obviously not now

Throttle servo - JRracing z590m
Steering servo - z4800s

So any suggestions PLEASE let me know because I'm at my whits end.
Thanks
trueimport is offline  
Reply With Quote
Old 03-28-2010, 06:31 PM
  #2  
dirtybird
My Feedback: (5)
 
Join Date: Jan 2002
Location: San Tan Valley, AZ
Posts: 5,768
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: twitching servo help PLEASE

Have you checked the batteries?
dirtybird is offline  
Reply With Quote
Old 03-29-2010, 12:24 AM
  #3  
trueimport
Thread Starter
My Feedback: (1)
 
Join Date: Aug 2008
Location: Lake Villa, IL
Posts: 90
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: twitching servo help PLEASE

The batteries in the buggy are fully charged and the ones in the remote are not new but still have about half power or more left.
trueimport is offline  
Reply With Quote
Old 03-30-2010, 12:08 AM
  #4  
dirtybird
My Feedback: (5)
 
Join Date: Jan 2002
Location: San Tan Valley, AZ
Posts: 5,768
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: twitching servo help PLEASE

If you have checked the batteries with a voltmeter with a load on them and they are up to what they are supposed to be, its time to take the set to a repairman.
dirtybird is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service