RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Hitec Electron 6 receiver

Reply

Old 07-24-2003, 02:07 AM
  #1  
jchumley
Senior Member
Thread Starter
My Feedback: (1)
 
jchumley's Avatar
 
Join Date: Dec 2002
Location: Dunkirk, MD
Posts: 381
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Hitec Electron 6 receiver

I bought a Hitec Electron 6 receiver at the LHS a few weeks ago and hooked it up to center the servos for installation and nothing happened. I have never used Hitec receivers before and I have misplaced the manual (hopefully it didn't get tossed). The Crystal is the correct type and matches my transmitter freq. The slots are channel 1 through channel 5 then a "batt/ch6" slot and then one that is not marked. I have tried the battery in both of the last two slots.

Is it a bum receiver/crystal or am I not doing it right? THe battery is charged too.

BTW, the hitec website doesn't have the electron 6 manual on line yet.

Jeff
jchumley is offline  
Reply With Quote
Old 07-24-2003, 05:31 AM
  #2  
3DFanatic
Senior Member
My Feedback: (5)
 
Join Date: Jul 2003
Location: Tacoma, WA
Posts: 2,668
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Hitec Electron 6 receiver

Hmm, a number of things could be wrong.

1. you're sure it's a Dual COnversion crystal?

2. You're sure the servo is plugged in properly? (Black ALWAYS faces out)

3. You're sure the battery is plugged in properly? (BTW, the battery will power your reciever no matter what slot it's plugged in to)

That's about all I can think of. If none of those work, try taking it back and getting another one.
3DFanatic is offline  
Reply With Quote
Old 07-24-2003, 06:01 AM
  #3  
JohnBuckner
My Feedback: (1)
 
JohnBuckner's Avatar
 
Join Date: Dec 2001
Location: Kingman, AZ
Posts: 10,419
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Add to Aaron's list:

Did you buy the proper one with modulation shift (positive or negative) to match your Tx?

John
JohnBuckner is online now  
Reply With Quote
Old 07-24-2003, 02:30 PM
  #4  
jchumley
Senior Member
Thread Starter
My Feedback: (1)
 
jchumley's Avatar
 
Join Date: Dec 2002
Location: Dunkirk, MD
Posts: 381
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Hitec Electron 6 receiver

THanks. It was too late last night. I should have gone to bed instead of posting this. The battery was plug was reversed. Works fine now, thanks.
jchumley is offline  
Reply With Quote
Old 07-24-2003, 04:42 PM
  #5  
3DFanatic
Senior Member
My Feedback: (5)
 
Join Date: Jul 2003
Location: Tacoma, WA
Posts: 2,668
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Hitec Electron 6 receiver

Hehe, I figured it was something simple Glad it's all worked out.
3DFanatic is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service