RC Submarines RC submarine discussions.

Lets hear about your Thunder Tiger Neptune SB-1.

Reply
Old 09-11-2012, 05:52 PM
  #226
bryantomosivitch
 
Join Date: Mar 2011
Location: middletown, NY
Posts: 18
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Lets hear about your Thunder Tiger Neptune SB-1.

I just wanna say you guys are the best. You help everybody.
bryantomosivitch is offline  
Reply With Quote
Old 09-11-2012, 07:41 PM
  #227
AQUASUB
 
Join Date: Sep 2009
Location: ocala, FL
Posts: 519
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Lets hear about your Thunder Tiger Neptune SB-1.

Thanks thats what i did ,r and r radio and new 2 each 11.1 5700 lipos,now she eats up the water!The dual rudders and dual kort knozels made a huge diference in manuverability like a mini van to a Mazarati!,will take pics.
Enjoy this great sub!
AQUASUB is offline  
Reply With Quote
Old 09-12-2012, 12:36 PM
  #228
glenladen
 
Join Date: Feb 2009
Location: Tom priceWestern australia, AUSTRALIA
Posts: 204
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Lets hear about your Thunder Tiger Neptune SB-1.

G'day Bryan,yes it is an 10 amp fuse.

cheers,
Glenn.
glenladen is offline  
Reply With Quote
Old 09-18-2012, 04:51 PM
  #229
bryantomosivitch
 
Join Date: Mar 2011
Location: middletown, NY
Posts: 18
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Lets hear about your Thunder Tiger Neptune SB-1.

Hey guys, i replaced the battery with a interstate battery. the old battery is 2.2ah, the new one is 2.3ah. But anyway i had no idea there was a weight difference. She was working the best it has ever. I get 15 feet out she starts going down. No response nothing. Come to find out i needed to take weight out. I think i got her dialed in now. Whem i tell you it runs 100 times better it does. Just by putting a new battery in. I would like to put lipos in but i gotta see what thats gunna take.
bryantomosivitch is offline  
Reply With Quote
Old 09-24-2012, 06:54 PM
  #230
bryantomosivitch
 
Join Date: Mar 2011
Location: middletown, NY
Posts: 18
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Lets hear about your Thunder Tiger Neptune SB-1.

Hey guys checking in. The sub is running good. The only thing is i went out prob 100 feet out in the water. She lost all sighnal. You would think went it gets closer and closer the sighal would come back. But it didnt. I turned it off then back on. and everything was ok. But anyway I think its time for a new radio. Anybody know a good radio? or i was gunna convert my futaba 10c 72mgz to 75mgz. I just want know the best radio.
bryantomosivitch is offline  
Reply With Quote
Old 10-10-2012, 05:43 AM
  #231
bryantomosivitch
 
Join Date: Mar 2011
Location: middletown, NY
Posts: 18
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Lets hear about your Thunder Tiger Neptune SB-1.

Hey man its bryan. I just wanted to say the longer I own this sub the more and more I enjoy it. I replaced the battery a huge change in performance. The only thing is she blew to fuses for the first time. It would blow after an hour of run time. The same type of battery just a better quality batt. Im getting 1 hour plus. I cant believe it. I just worried why it blew to fuses . I think it was due to long run times. I am gonna post some pics Im gonna put a camera mounted on the outside of the sub, and run a cord all the way to the surface to a monitor. I looked at your post from awhile back about rerouting the antenna wire and that worked ,but im gonna buy a better radio. I just wanted to give you guys an update and see if theres any other forms. Thank you for all recommendations they were all right.
bryantomosivitch is offline  
Reply With Quote
Old 11-06-2012, 04:16 AM
  #232
glenladen
 
Join Date: Feb 2009
Location: Tom priceWestern australia, AUSTRALIA
Posts: 204
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Lets hear about your Thunder Tiger Neptune SB-1.

G'day all, Idid the same thing as Bryan and changed out my battery with a new one still an 2.2Ah but she works fine and the ballast pump is doing its thing,I just need to reballast it to totally sibmerge.

cheers,
Glenn.

http://s172.photobucket.com/albums/w...10-20126-1.mp4


http://s172.photobucket.com/albums/w...5-10-20125.mp4
glenladen is offline  
Reply With Quote
Old 09-27-2013, 06:40 AM
  #233
manila_eagle
 
Join Date: Jun 2008
Location: Boron, CA
Posts: 53
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Is this forum dead or hybernating? Is there anyone there?
manila_eagle is offline  
Reply With Quote
Old 10-21-2013, 06:04 AM
  #234
glenladen
 
Join Date: Feb 2009
Location: Tom priceWestern australia, AUSTRALIA
Posts: 204
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

G'day manila_eagle, I think it's hibernating.
glenladen is offline  
Reply With Quote
Old 10-21-2013, 01:10 PM
  #235
manila_eagle
 
Join Date: Jun 2008
Location: Boron, CA
Posts: 53
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

G'day glenladen, glad someone still awake I recently purchase an SB-1 RTR, do you know if all or some of the problems mention at this forum are been corrected by the mfg. or still a problem today? Thanks.
manila_eagle is offline  
Reply With Quote
Old 10-21-2013, 05:22 PM
  #236
glenladen
 
Join Date: Feb 2009
Location: Tom priceWestern australia, AUSTRALIA
Posts: 204
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

G'day manila_eagle, I'm not sure if the problems with the supplied chargers have been rectified or with the radio's either.I changed the radio out on mine because 72Mhz is illegal to use in Australia and battery charger required an adapter to be plugged into our power outlets (different pin setup),that and the charger just wasn't up to the job so I now use my swallow eq250 multi charger instead.


Hopefully someone who has recently purchased one might like to bring us up to date on these issues.

cheers,
Glenn.
glenladen is offline  
Reply With Quote
Old 11-15-2013, 12:19 PM
  #237
manila_eagle
 
Join Date: Jun 2008
Location: Boron, CA
Posts: 53
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

glenladen, the charger that came with mine works well, at first I thought it will not because of the connector wont slide in at the sub battery charger connector, but by forcing it, it does fit well. I charge the battery over night and reads 13+ volts the next morning. I am still looking for a connector adapter for the video camera power connector at the sub to connect my wireless video camera that I have. No problem here about the radio system, I am just going to test & run the sub at my swimming pool. I hope I will have sometime this weekend to work on this hobby.

Thanks for your info. & have a happy weekend.
manila_eagle is offline  
Reply With Quote
Old 07-05-2014, 11:31 PM
  #238
Paul60
 
Join Date: Apr 2014
Posts: 99
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I have one of these subs.

Anyone still running, modding theirs ?

Mine is stock except I put in a re-settable fuse and the 6 blade prop.

I'll get around to a video link & some lights some day.
Paul60 is offline  
Reply With Quote
Old 07-06-2014, 01:06 PM
  #239
Remote
Thread Starter
 
Join Date: May 2002
Location: Dover, FL
Posts: 140
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I started this thread on 06-19-2010, 07:10 AM. As of today, my sub is still in the box, never seen water... *LOL* Maybe one day I'll get it out. Have any pics of your sub you would like to share? After getting this reply, I may just have to pull it out of the box. I bet I need a new battery.
Remote is offline  
Reply With Quote
Old 07-06-2014, 04:06 PM
  #240
Paul60
 
Join Date: Apr 2014
Posts: 99
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I'm much the same.

Bought it new last year & so far it's only voyage has been in my bathtub !

I fitted a new re-settable fuse (as i could see it becoming tedious to keep buying replacements) & bought the 6 blade prop from Omnimodels. That was fun fitting that too.

I don't like the fact I have to pull half the front off just to charge the battery.

Mine arrived with all the internal ballast weights loose and I had to disassemble lots more to slide them back onto the ballast bar and re-tighten them.

Then, if they are not in the right position you have to dismantle the sub and adjust them again. Tedious !

All that work kinda put me off a bit.

One day I might try it with a camera and see if I can renew my enthusiam.

I'll try and get some pics. It's stock except for the fuse & that 6 blade prop.

I'm not sure how well those 12v lead batteries hold up? I bet mine is getting a bit dodgy after 12 months too!
Paul60 is offline  
Reply With Quote
Old 07-06-2014, 05:17 PM
  #241
Remote
Thread Starter
 
Join Date: May 2002
Location: Dover, FL
Posts: 140
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Not sure if AQUASUB is still around, but he was the man to go to when it came to the Neptune. Would have loved to see his sub in action.
Remote is offline  
Reply With Quote
Old 07-06-2014, 05:33 PM
  #242
Paul60
 
Join Date: Apr 2014
Posts: 99
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Yes, I have been reading through some of his posts. Sounds like he has modded the hell out of it. I like the twin props!

I think the fuse & prop upgrades are worth doing. I am seriiously considering the video & monitor kit & some of those light kits that Mike's Subworks sells.

Have you dusted off the box yet ? You could do an 'Un-Boxing' vid for youtube !
Paul60 is offline  
Reply With Quote
Old 07-07-2014, 09:01 AM
  #243
Remote
Thread Starter
 
Join Date: May 2002
Location: Dover, FL
Posts: 140
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I need to check into the fuse mod. Was that posted in this thread? Its been so long I don't remember if it was or not. twin props? I need to check into that also.
Remote is offline  
Reply With Quote
Old 07-07-2014, 04:02 PM
  #244
Paul60
 
Join Date: Apr 2014
Posts: 99
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I don't know where I saw the fuse mod, but I had visions of that 10amp fuse blowing a lot, so I just bought one of these;

http://www.ebay.com.au/itm/NARVA-10A...ht_2136wt_1249

Fits like a glove & great quality.

The twin props I just spotted on here yesterday in one of Aquasubs mod threads. Looks awesome. Way beyond my skills though !
Paul60 is offline  
Reply With Quote
Old 07-07-2014, 04:13 PM
  #245
Remote
Thread Starter
 
Join Date: May 2002
Location: Dover, FL
Posts: 140
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Need to see if I can find that fuse here in the states or find somebody that sells them and ships to the states... Maybe he will ship to the states. His auction states:
Posts to: Australia. I will have to ask
Thanks for the link....

Last edited by Remote; 07-07-2014 at 04:16 PM.
Remote is offline  
Reply With Quote
Old 07-08-2014, 03:08 AM
  #246
Paul60
 
Join Date: Apr 2014
Posts: 99
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

(I looked too, seems like they are an Australian product and no overseas shipping) ?

Let me know if you can't get one. I'm happy to send you one.
Paul60 is offline  
Reply With Quote
Old 07-08-2014, 03:27 PM
  #247
Remote
Thread Starter
 
Join Date: May 2002
Location: Dover, FL
Posts: 140
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Thanks Paul, I just may take you up on your offer if I cant find one...
Remote is offline  
Reply With Quote
Old 07-08-2014, 06:19 PM
  #248
Remote
Thread Starter
 
Join Date: May 2002
Location: Dover, FL
Posts: 140
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Here is a picture of mine, still in the box where its been for years.
Remote is offline  
Reply With Quote
Old 07-08-2014, 06:33 PM
  #249
Paul60
 
Join Date: Apr 2014
Posts: 99
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Looks like you have an OCD with boxes too!

I keep almost every box that a new toy comes in. Don't ask me why !

You have some cool looking stuff there. What old nitro heli is that bthway ?

PS, If you ever want that fuse just yell out. You'd think they would be a common item ?
Paul60 is offline  
Reply With Quote
Old 07-09-2014, 12:50 PM
  #250
Remote
Thread Starter
 
Join Date: May 2002
Location: Dover, FL
Posts: 140
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

The nitro heli is a Hirobo Sceadu. I put about a 1/2 gallon of fuel through it and put her on the shelf. I was too worried about crashing it I could not enjoy flying it. *LOL*

Remote is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:07 PM.