Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Loss of radio contact

Reply
Old 11-15-2010, 08:45 AM
  #1
thorMaXx
Thread Starter
 
Join Date: Sep 2009
Location: Maryville, IL
Posts: 8
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Loss of radio contact

Hey guys, i have an issue that completely has me boggled.

Was out yesterday with the monsoon, and after roto start button issues and back plate issues, i put the pull start back on it and finally got the thing going.

The monsoon was running good, when I collided with my friends truggy and i flipped over. I lost all radio contact at this point. While i was going over to filip
it back over, I tried braking to stop tires and nothing happened.

Once i got it flipped over, i tried everything on the transmitter and nothing worked. I replaced all batteries in transmitter and receiver and still nothing.

Any thoughts on why i would suddenly lose all radio contact? The collision wasnt violent, was just in front of a jump and the jump caused it to roll over.

Any thoughts or advice would be appreciated.
thorMaXx is offline  
Reply With Quote
Old 11-15-2010, 10:45 AM
  #2
Torch39
 
Torch39's Avatar
 
Join Date: Aug 2010
Location: Mahopac, NY
Posts: 101
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Loss of radio contact

Sound like u dmg the main box that the wires go from to both you throttle and steering servo. If neither of thoseservosare responding Iwould check the main box. Probally needs to be replaced.
Torch39 is offline  
Reply With Quote
Old 11-15-2010, 03:41 PM
  #3
bcox13
 
Join Date: Nov 2009
Location: Maryville, IL
Posts: 7
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Loss of radio contact

I think the car got sick of you not being able to drive.[X(]  LOL
bcox13 is offline  
Reply With Quote
Old 11-16-2010, 12:21 PM
  #4
thorMaXx
Thread Starter
 
Join Date: Sep 2009
Location: Maryville, IL
Posts: 8
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Loss of radio contact

Thanks torch. Ill test the main box and see.

bcox, Actually, im guessing it got tired of embaressing your Losi Eight!
thorMaXx is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 03:23 PM.