Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5

  1. #1

    Join Date
    May 2011
    Location
    , NJ
    Posts
    10
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Tornado S30 Problem

    i just received my redcat buggy in today. open package up and everything was working great. broke in the first tank letting it just sit there without a problem. second tank driving it around in 8 also without any problems. 3rd tank again no problems. now i go and start the 4th tank break in process and rite when i turned everything on my cars electronics started going crazy. steering motor started making wierd noises when i turn it doesnt react as quickly to my inputs. the motor that turns the throttle also does not act correctly. i tired resetting the reciever and controller already witout any success. anyone else started having this problem half way through their break in. im very dissapointed this started happening out of nowhere.. tried calling redcat but its closed already. this isnt my first nitro car. i have 3 yokomo gt4's. thanks in advanced.

  2. #2

    Join Date
    Oct 2006
    Location
    Oakland, TN
    Posts
    226
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Tornado S30 Problem

    My first guess would be check electronics, battery, connections, etc. Other than that, sounds like bad interference somehow. Mine usually jumps around a bit when I touch the glow plug igniter to the engine, but not crazy like this.

  3. #3

    Join Date
    May 2011
    Location
    , NJ
    Posts
    10
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Tornado S30 Problem


    ORIGINAL: jaofos

    My first guess would be check electronics, battery, connections, etc. Other than that, sounds like bad interference somehow. Mine usually jumps around a bit when I touch the glow plug igniter to the engine, but not crazy like this.
    now that you mention it i do live next to a middle school. less than a football field from it. could it be that im getting crazy interference from the alarm??? it was good one minute and the next minute it was going crazy. now the motor that controls the steering is making a crazy noise when i try to steer it. im really worried that the interference messed something up. tomorrow im going to contact redcat and see what they can do. luckily i do live real close to a hobby store that is an authorized redcat dealer who stocks parts.



  4. #4

    Join Date
    Feb 2006
    Location
    howard beach, NY
    Posts
    16,490
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Tornado S30 Problem


    ORIGINAL: 05tegtyper

    i just received my redcat buggy in today. open package up and everything was working great. broke in the first tank letting it just sit there without a problem. second tank driving it around in 8 also without any problems. 3rd tank again no problems. now i go and start the 4th tank break in process and rite when i turned everything on my cars electronics started going crazy. steering motor started making wierd noises when i turn it doesnt react as quickly to my inputs. the motor that turns the throttle also does not act correctly. i tired resetting the reciever and controller already witout any success. anyone else started having this problem half way through their break in. im very dissapointed this started happening out of nowhere.. tried calling redcat but its closed already. this isnt my first nitro car. i have 3 yokomo gt4's. thanks in advanced.*

    if its a 2.4 radio, try rebinding it and use some fresh batteries.
    125 characters and 2 lines is not enough to list my RC obsession!!!

  5. #5

    Join Date
    May 2011
    Location
    , NJ
    Posts
    10
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Tornado S30 Problem

    i juat tried doing that with fresh AA's and nothing. as soon as i turn on the throttle servo goes completely the opposite way ( closes the carb all the way and when the motor is on it bog's the motor almost to shut off) =[[[


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 09:02 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.