Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Page 3 of 3 FirstFirst 123
Results 51 to 69 of 69

  1. #51

    Join Date
    Apr 2010
    Location
    Phoenix, AZ
    Posts
    7
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    Hello,

      We are still waiting for the updated parts to come in from China, as we seem to be much closer to having a fix for the problem.  Once we get them in, we will test the parts to make sure everything fits like it should.  If everything goes according to plan, we will be able to send parts out to you soon.  Thank you for your patience in this matter.

    Thanks,
    Billy
    Redcat Racing

  2. #52

    Join Date
    Aug 2011
    Location
    Grande Prairie, AB, CANADA
    Posts
    68
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....



    Sorry, i am trying to be very patient. It's just a little fustrating.......

    I've ordered 2 more sets of guts for the front/rear diffs ( this will be set number 3). Takes about 7 days or so days to get here from the redcat dealer thats across canada. My LHS is all backordered on the 8e diff parts and also the BS17mm-KIT that i've been desperatly looking for in Canada and now not much luck finding one in the States also, what's happening with the shortage of parts?

    I've also ordered the shim set 903-091, now i'm NOT sure if they will fit on the inside of bearings, to stop the side to side play in the diff, i hope that they do. Does anyone know or are they just for the drivecup shims?? I will try to shim it as best as i can until REDCAT resolves the problem.

     Not much of the season left and haven't been out with my mine since i got it, just watching my kids play with theirs and waiting for them to get bored so i can try theirs.....


  3. #53

    Join Date
    Apr 2010
    Location
    Phoenix, AZ
    Posts
    7
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    We were out of the 17mm kit's for awhile, but now we have them back in stock.  I have no problem sending you one of them (free of charge) with the parts we send you for the gearboxes soon.  Would this work for you?

    Also, there is no parts shortages per-say that we are aware of.  We just ran out of stock on the 17mm kits, and the recent spring of gearbox problems cleaned us out of differential parts.  There is definitely nothing to worry about when it comes to parts, as we usually stock everything for our vehicles and we don't usually end up being out of something for more than a week before our supply is replenished.

    Regarding the shims (BS903-091), these will only work for the pinion shaft bearings.  You will need something with a 12mm inside diameter to act as a shim for the side to side play of the differential.  Unfortunately we do not carry any shims of this size yet.  Your best bet would be to check with your local hobby shop for something of this nature for the time being if you are looking to shim your gearbox.

  4. #54

    Join Date
    Aug 2011
    Location
    Grande Prairie, AB, CANADA
    Posts
    68
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....



    Thanks for helping to get this problem fixed, greatly appreciated.....

    As for the 17mm-kit and the gearbox parts, ya that will do! Truste me i'm happier that you guys may have fixed this problem than me getting free stuff. I just want to drive this thing that's all...but yup, keep me posted and during the meantime i'll try to shim this thing and see how this works for it.

    I put in a order at my LHS, which is a redcat dealer, for the 17mm-kit, the diff gears, complete diff and some other things over a month ago and they have been backordered since then. I know they got a shipment in because 2 weeks ago they had all new redcat stuff and the new shredder line-up was out.  Maybe my parts will be here soon also then. 

    I'll let you know if i don't get the 17mm kit............i got three other set of tires and rims that i dying to try,  so i'll see what happens, if i can get the diffs to stay together, i'll probably already have 17mm kit as soon as it gets here, but who knows.
    Thanks Bill


  5. #55

    Join Date
    Aug 2011
    Location
    Grande Prairie, AB, CANADA
    Posts
    68
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    UPDATE........

    Finally got my diffs parts ( not from Redcatbilly, they are however almost completed, i was told) from across Canada. So still haven't drove it any more than 20mins in almost 2 months.  During that tme i ripped it all apart and put back together, loctite the steel screws and replace any that didn't seem to hold.  RE-SHIMMED the front and rear diffs- put 2 shims on the drive cup, to which there was already 2 there. so a total of 4 on the drive cup, and one behind the spur gear bearing. OK things do seem a little tight for me, but decide to try it anyway, see how it goes like that. No play at all now. Use the machined screw with a nut to keep things tight together.  Took it out for a test, all was good then about 10mins in, i lost the 4mm hex fine thread srcrew with the aluminum bushing that keeps the carrier in the c-hub.  @#$%$#, whatever, go to the LHS, who is redcat dealer, get the part, BUT they were different and after doing some research, figured out the problem, BUT again no parts here..........
    So order from Dennis (AKA THE MAN, good job Dennis.) just gotta wait AGAIN, Down for another 10-12 days....

    ...........par for the course i guess[]

  6. #56

    Join Date
    Aug 2011
    Location
    Grande Prairie, AB, CANADA
    Posts
    68
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    UPDATE..........

    Ok, so Redcat Billy has contacted me and has shipped out parts and the new diffs for the Earthquake 8e.... GOOD F%$#&$N JOB REDCAT in taking a real interest into the diff problem....
    Keep up the good work and you'll have a good solid clientell relations.....
    i will keep everyone posted on how everything is going



    I WILL SAY THAT REDCAT DOES HAVE #1 CUSTOMER SERVICE.  THE BEST THAT I HAVE EVER EXPERIENCE IN ANYTHING SO FAR.





    he, he, he,  ( giggling like a little school girl on her first date...)  can't wait for the parts to arrive now and take her out for a ride

  7. #57

    Join Date
    Aug 2011
    Location
    Grande Prairie, AB, CANADA
    Posts
    68
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    UPDATE AGAIN............................................. .............................

    ok well got the parts from Redcat today. I HAD TO PAY BROKERAGE FEE OF $11.81, FOR PARTS THAT WERE REPLACEMENT PARTS.!!!!
    I know it's only 11.81 but thats half of the cost of parts. oh well, nothing is for free, thats for sure....

    so put the new diffs in today, they do seem to have no play at all now. Test drove and problems with the batteries or something......yup thats my luck 

  8. #58

    Join Date
    Aug 2011
    Location
    Grande Prairie, AB, CANADA
    Posts
    68
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    UPDATE NEW EARTHQUAKE 8E STILL ON THE SHELVE

    ok so today i should be able to pin point what's wrong by trial and error...... for some reasom so far the main power line which connects to the battery, the black and red wire, not the red/red wire, is getting very hot and so is the battery that it is connected to........

    any ideas?? doesn't seem to matter which battery i used, the main power line and battery connected to it gets hot.....
    would a faulty esc do this???? 

    im going to change the battery connectors today and see if that helps...  

  9. #59

    Join Date
    Feb 2006
    Location
    howard beach, NY
    Posts
    16,490
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    sounds like a short in the esc to me, does the esc get hot or does it smell burnt?
    125 characters and 2 lines is not enough to list my RC obsession!!!

  10. #60

    Join Date
    Aug 2011
    Location
    Grande Prairie, AB, CANADA
    Posts
    68
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....



    no is doesn't get hot but, the fan squeals ( makes a high pitch sound) for about 10 secs. That was like that out of the box. I just tap under the esc and seems to speed up the recover time of the squeal. I did put a little of contact cleaner, and just a little WD, then air it out, when i first got it, didn't seem to help, just the tapping......

    ok so i changed over the battery connectors and on the quake to deans.... NOW it won't come on or anything....
    i sauldered (??) the same as the bullet connectors.. all of the red wires from the battery coincide with the reds of the esc, both plugs are wired the same on the quake , red/black with red/red but the connecters are the same.......

    did i do something wrong here????

    the batteries work great in the other rc's


  11. #61

    Join Date
    Feb 2006
    Location
    howard beach, NY
    Posts
    16,490
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    that squeal is the bearing or bushing of the fan, most of the times a tap of it will make it go away, wd can actually clean the grease out of bearings or bushings so i wouldnt suggest it, its good for cleaning. Sounds like you either wired something wrong with the deans, bad connection or your esc is shot.
    125 characters and 2 lines is not enough to list my RC obsession!!!

  12. #62

    RE: I'm so disappointed with THE QUAKE 8e....


    ORIGINAL: Weekend Warriors

    UPDATE NEW EARTHQUAKE 8E STILL ON THE SHELVE

    ok so today iΒ*should be able to pin pointΒ*what's wrong by trial andΒ*error...... for some reasom so far the main power line which connects to the battery, the black and red wire, not the red/red wire, is getting very hot and so is the battery that it is connected to........

    any ideas?? doesn't seem to matter which battery i used, the main power line and batteryΒ*connected to it gets hot.....
    would a faulty esc do this????Β*

    im going to change theΒ*battery connectors today and see if that helps...Β*Β*
    What ESC does that truck have? Is it the EZ-Run from turnigy, because if it is, pack it up and send it back. I just got a shipment of Ten Turnigy EZ-Run ESCs direct from Turnigy and two of them actually burst into flames on the inside when we hooked up the battery to them, unbelievable.
    Dealer for..Redcat, Traxxas, Associated, Cen, Racers Edge, RD Logic, Losi, HPI, E-flight, Himoto, Venom, Heli-Max, O.S...etc

  13. #63

    Join Date
    Aug 2011
    Location
    Grande Prairie, AB, CANADA
    Posts
    68
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    yup bad connections, oops my bad............gonna get fix asap..

    no it's the hobbywing 80a or sumthing like that ...
    thanks guys for the info

  14. #64

    Join Date
    Aug 2011
    Location
    Grande Prairie, AB, CANADA
    Posts
    68
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    UPDATE-

    Ok so after fixing the cold solder mess up. The stock batteries don't seem to last at all. Maybe 5mins, then the lipo cut off kicks in i believe......i will try to discharge and charge those batteries.... as soon as i get one. I put in my 5000mah, 30c, lipos and it ran great for it's first test drive, just in the park across from my house......we might take out the Earthquake 8e today and give her a good test run with the new diffs.......



    may not......... there's one sick kid who stayed home today.....too sick for school, too sick for rc'n..............maybe not

  15. #65

    Join Date
    Sep 2011
    Location
    Portland, OR
    Posts
    28
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    Do't discharge them, just charge them or Balance them. I believe that you posted that you updated your charger.


    Bummer about all the problems you've gone through. I will say that RC staff has been helpful with most and all of my questions. As a Dealer I have to deal with lost of customers and their issues etc. They have always done well to rectify any problem.



    I feel your pain, i have a customer who has also gone through quite the ordeal to get his truck operating properly.




    MOmo

  16. #66

    Join Date
    Aug 2011
    Location
    Grande Prairie, AB, CANADA
    Posts
    68
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....



    Thanks for felling my pain.......ya i was gonna buy a charger that can also discharge the battery. My LHS convinced me that i don't need to, just charge and balance them and they should be fine. So i brought my redcat batteries to them and he said that one pack was fried.... nice..... par for the course

    nothing but a hassle


  17. #67

    Join Date
    Sep 2011
    Location
    Portland, OR
    Posts
    28
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    I've had a couple customers whose lipo packs died after little use.

    All i can say is that their warranty is pretty good and usually will take care of it. I've even gotten NIP packs loose that appeared "swelled" before even using them in anything.


    I would recommend a good "Blinky" just to check the cells balance every so often, but i wouldn't balance every time. I used to balance every time, but a friend who works for Venom says its not necessary. I would use a blinky every couple of times not always the balancer. Also, given the volitility of the RC lipo packs, I would invest in a lipo bag or something metal for safe charging.



    MOmo

  18. #68
    formula87's Avatar
    Join Date
    Dec 2009
    Location
    hampton roads, VA
    Posts
    780
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    Warrior........ I bought the EQ when they first came out Dec -09 Jan- 10 first 4 min out uf the box I tried to see ifitcould take out an oak tree OUCH! ..........that thing was tore up......... new diff case, gearsect........ the whole front end...... good learning exp.......my first ever brushlessnot to mention 1/8th scale........ all back together .........chewing up diffs........... front thenrear.......
    Kurtat URC Hobby (plug)was great in getting me replacements and I got help from Redcat also in new pinions and ring gears and shims..... made a fewyoutube vids about what happend and what I did....... after shimming worked great........... I have moved on from my EQ and converted to a BD no more problems and handles way better......... those big tires and the pwr of the Brushless systemwas too much for the diffs.........but for $300......it was a greatRC to learn on and I do not regret getting it............... plus on 4s it would blow away my buds Savage Flux he had to run 6S to beat me. thought thatwas funny .
    Traxxas Slash VXL / sold ECO
    Traxxas Slash MMpro/17.5 Novak
    Blade MSR X /J3 Cub
    Cayuga82 on youtube

  19. #69

    Join Date
    Sep 2011
    Location
    cary, IL
    Posts
    92
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: I'm so disappointed with THE QUAKE 8e....

    if you are wanting a hardened steel ring/pinionupgrade i asked redcat to e-mail me when it come in stock.i can let you know when that happens (yeah right!).or if you want the # i can look for it.i put earthquake tires on the 15t aftershock and within minutes the rear dif blew.nothing left of the pinion.imo its a pinion temper problem not a backlash problem.if the pinion was loose it would of took the teeth out and left the collar.


Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 01:08 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.