Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

just a quick question

Reply
Old 03-22-2012, 05:27 AM
  #1
Shady9503
Thread Starter
 
Join Date: Mar 2012
Location: brampton, ON, CANADA
Posts: 143
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default just a quick question

Hey guys so i have a quick question, when i block my exhaust to shut off my buggy (tornado S30) it just keeps on running lol car runs great and i love it but im assuming i have a leak somewhere? and im having trouble getting the engine primed when i block the exhaust aswell
Shady9503 is offline  
Reply With Quote
Old 03-22-2012, 05:47 AM
  #2
bigblueford
 
bigblueford's Avatar
 
Join Date: Oct 2011
Location: Muscatine, IA
Posts: 12
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: just a quick question

I agree, does sounds like you've got a leak. First place I would check would be the little blue rubber coupling between the exhaust header and muffler. It shouldn't have any holes or tears in it. It should two tie-wraps, one to clampit to the header and one to clamp it to the muffler.

Also check to make sure the header flange screws are tighten down.


bigblueford is offline  
Reply With Quote
Old 03-22-2012, 06:34 AM
  #3
Shady9503
Thread Starter
 
Join Date: Mar 2012
Location: brampton, ON, CANADA
Posts: 143
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: just a quick question

hey well i know its not that rubber coupling cuz i changed it the other day for that exact reason lol had a tear in it :P
but the header flange screws? im not exactly sure what those are? ive only been in this hobby a year but im obsessed lol getting my next RC this monday also could a bad manifold gasket be the cause aswell?
Shady9503 is offline  
Reply With Quote
Old 03-22-2012, 06:39 AM
  #4
bigblueford
 
bigblueford's Avatar
 
Join Date: Oct 2011
Location: Muscatine, IA
Posts: 12
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: just a quick question

There are two small screws that attached the exhaust header to the engine block, your manifold gasket goes between the header manifold and the engine block, so the two screws I'm talking about also hold the manifold gasket in place.

bigblueford is offline  
Reply With Quote
Old 03-22-2012, 06:46 AM
  #5
Shady9503
Thread Starter
 
Join Date: Mar 2012
Location: brampton, ON, CANADA
Posts: 143
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: just a quick question

ahhh ok i see what your talking about, yess i know those screws i tightned them myself a week ago but i think i did it too much and might have wrecket that gasket, could that be my problem? also missing one screw from my pullstart must have lost it bashing and now theres a small opening
Shady9503 is offline  
Reply With Quote
Old 03-22-2012, 07:11 AM
  #6
bigblueford
 
bigblueford's Avatar
 
Join Date: Oct 2011
Location: Muscatine, IA
Posts: 12
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: just a quick question

Missing pullstart screw won't cause the leak, but should be replaced. Sounds like maybe you should retighten all the nuts and bolts. Get yourself some blue locktite and use it on the screws to help hold them tight for a longer period time. Go thru the entire car and remove one screw at a time, put blue locktitre on it, and reinstall snuggly. Be careful not to over tighten and strip out the hole.

Remove the muffler, hold your finger over the exhuast pipe, and blow into the end with the rubber coupler. It should not leak air.

bigblueford is offline  
Reply With Quote
Old 03-22-2012, 08:23 AM
  #7
Shady9503
Thread Starter
 
Join Date: Mar 2012
Location: brampton, ON, CANADA
Posts: 143
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: just a quick question

Thanks for your help
ill do everything you just said and let you know!
Shady9503 is offline  
Reply With Quote
Old 04-02-2012, 03:38 PM
  #8
allenmiller25
 
Join Date: Mar 2012
Location: washington, NC
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: just a quick question

check for a air leak around the pinch bolt that holds the carb on i beat my self to death for three weeks with a redcat caldera that was leaking air
allenmiller25 is offline  
Reply With Quote
Old 04-03-2012, 04:25 AM
  #9
Shady9503
Thread Starter
 
Join Date: Mar 2012
Location: brampton, ON, CANADA
Posts: 143
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: just a quick question

Thanks for all your help guys! i found the leak the gasket from the engines exhaust port to the manifold was pretty much disintegrated :P i changed it and everythings good she runs like a dream
Shady9503 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:35 AM.