Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 2 of 2

  1. #1

    Join Date
    Jun 2012
    Location
    , OK
    Posts
    4
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    New Backdraft 8E Problems

    So I finally was able to get my factory charger and charge my batteries so i could run my car again. I go out to run and it works for about 2 minutes then quits. The ESC blinks red after it quits and it says that means low voltage shut off. What the hell does that mean and how do I fix it? For God's sake I jsut want to run my new car! Help, please!

    -SB

  2. #2

    Join Date
    Jun 2010
    Location
    Evansville, IN
    Posts
    64
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: New Backdraft 8E Problems

    It sounds like your batteries are not holding a charge. Try different batteries?

    The LVC is there to save your LiPo batteries from discharging to a level that may damage them. In your case the voltage on the batteries may already be to low to meet the required amount.
    Associated Rc8, Redcat Earthquake 8e, Losi Mini-t, Traxxas: Jato, Slash, TCP, and E-Maxx


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 08:10 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.