Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1

    Join Date
    Dec 2012
    Location
    Clifton ParkNY
    Posts
    42
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Battery charging error,,,HELP

    Hi everyone,Ive been charging my boys LIPO batteries with no issues the past couple of months until today,Im getting the "battery voltage cell error" on the Thunder AC6 dual charger.I only get this error if Iplug the cell lead in the XH adapter,whether I straight charge it,balance charge it or fast charge it.I dont get the error if I dont use the XH adapter,anyone have any ideas what it could be?Im charging the at 3a 7.4v 2S,the batteries are Gens Ace 5000mh 40C batteries with the banana plugs,Any help is appreciated.

  2. #2

    Join Date
    Dec 2012
    Location
    Clifton ParkNY
    Posts
    42
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Battery charging error,,,HELP

    After trying a different lipo,it appears that the lipo that gives the error is at fault for some reason,the other lipo charges fine with no errors.Is the battery defective?It still works.......

  3. #3
    nitrosportsandrunner's Avatar
    Join Date
    Aug 2007
    Location
    skowhegan, ME
    Posts
    9,054
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Battery charging error,,,HELP


    ORIGINAL: jroptop

    After trying a different lipo,it appears that the lipo that gives the error is at fault for some reason,the other lipo charges fine with no errors.Is the battery defective?It still works.......
    voltage cell error means the charger doesnt see 2 cells. You input that its a 2cell lipo, but it cant read that there are 2 cells in the pack. Most likely, a connection inside the pack has failed. Ive had this happen with a skylipo.
    Downside to buying cheap packs. Ive owned probly 10 skylipo packs, 3 of which have failled in some way(after a fair amount of use)
    It doesnt bother me, since the money I spent on the 10 packs would have only bought me maybe 3 Big Brand packs.

    I have a "blinky balancer" which is a small card that plugs into the balance plug on a lipo. It 1st displays the # of cells, and then the voltage of each. When I have a problem with a pack, I plug it in. If it reads 1 cell when I plugged in a 2s lipo, then I know the lipo is bad. Or if the cells are way out of balance I know there may be an issue.
    SC10rs, 1/6 hummer crawler, Kyosho Twin Force, Lunchbox project, Techone P51,


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 09:22 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.