Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

clutch shoes

Reply
Old 06-06-2013, 09:54 PM
  #1
Shady9503
Thread Starter
 
Join Date: Mar 2012
Location: brampton, ON, CANADA
Posts: 143
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default clutch shoes

so the plastic clutch shoes on my sh.28 are finished, so im switching them out with alum clutch shoes, now my question is, one shoe goes on easily and when i pry it open as if it were engaging from its rested position and let go it will return to normal, but the other two wont, they will stay where they are, is this normal with new shoes do i just need to run them for them to work properly? or did i do something incorrectly?
Shady9503 is offline  
Reply With Quote
Old 06-08-2013, 10:53 AM
  #2
rchobbyunlimited
 
rchobbyunlimited's Avatar
 
Join Date: Nov 2009
Location: Riverdale, GA
Posts: 383
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: clutch shoes

yes you have done something wrong all of them should return back against the shaft when not engage. Have you made sure that all of the spring ends is behind the clutch nut?
rchobbyunlimited is offline  
Reply With Quote
Old 06-08-2013, 10:26 PM
  #3
Shady9503
Thread Starter
 
Join Date: Mar 2012
Location: brampton, ON, CANADA
Posts: 143
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: clutch shoes

Yes but what im not sure about is which direction the flywheel nut gets screwed on, theres a side thats slightly longer than the other so i was wondering if thats the side that makes contact with the flywheel or not?
Shady9503 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:18 AM.