Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Broke servo please help!!!!!!!!!!!!!!!!!!!!!

Reply
Old 11-05-2013, 05:39 PM
  #1
joed23
Thread Starter
 
Join Date: Nov 2013
Posts: 9
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Broke servo please help!!!!!!!!!!!!!!!!!!!!!

Hey i got a new redcat sandstorm baja truck this is my first rc car and i dont no SMACK ABOUT ANYTHING. when i turn right the servo makes like a jammed noise and vibrates .i looked around the servo area and found nothing wrong with.I put up a vid on YouTube and so far got no views so i came on her thinking that people would help me out but my last thread on this got no replies so im posting it again! Video= http://www.youtube.com/watch?v=zut4EH-jBZ4
joed23 is offline  
Reply With Quote
Old 11-07-2013, 05:14 PM
  #2
rchobbyunlimited
 
rchobbyunlimited's Avatar
 
Join Date: Nov 2009
Location: Riverdale, GA
Posts: 383
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

It sounds like the gears are stripping somewhere eithier the gears in the servo or the teeth on the servo are are slipping. Take the servo horn off and see if its still making the same noise if so then you know its the servo.
rchobbyunlimited is offline  
Reply With Quote
Old 11-07-2013, 05:16 PM
  #3
rchobbyunlimited
 
rchobbyunlimited's Avatar
 
Join Date: Nov 2009
Location: Riverdale, GA
Posts: 383
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Your old thread on here does have replies and ther are telling you the same thing I am saying.
rchobbyunlimited is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:45 AM.