Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 11 of 11

  1. #1

    Redcat Sandstorm HELP! PLEASE HELP ME!

    Hellp again please! http://youtu.be/CHLYhYyv1VM

  2. #2

    Join Date
    Apr 2010
    Location
    Phoenix, AZ
    Posts
    7
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Hello,

    Your problem seems to be that you have the plug from the ESC plugged into the VCC port in the receiver, when it should be plugged into CH2. This is why you are still getting power to your servo, but your radio trigger is not controlling the ESC.

    Thanks,
    Billy Fischer
    Redcat Racing

  3. #3
    Thanks for your support! But even when i put the ESC cable in the CH2 spot the car never seems to move

  4. #4

    Join Date
    Apr 2010
    Location
    Phoenix, AZ
    Posts
    7
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    No problem! Your best bet will be to give our shop a call and speak to one of our technicians when you have your vehicle and radio in front of you. They will help you through some troubleshooting and will hopefully be able to get you up and running over the phone. (602) 454-6445. We are open Monday-Friday, 8:00am-4:00pm, Arizona time.

  5. #5
    Thanks man!

  6. #6

    Join Date
    Apr 2010
    Location
    Phoenix, AZ
    Posts
    7
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    No problem! I really hope we can get this worked out over the phone.

  7. #7
    nitrosportsandrunner's Avatar
    Join Date
    Aug 2007
    Location
    skowhegan, ME
    Posts
    9,285
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    my guess is your throttle trim on the radio got moved....so when you turn on the car it does not sense Neutral position from the radio and thus will not arm.
    Put the truck on a box or something so that the wheels are not on the ground. turn it on, and then slowly adjust the throttle trim until the motor starts to move a little. then back it off a tad and it should be in neutral position and the throttle should now work.
    The other option which will accomplish the same thing is to recalibrate the ESC.
    Hold that button by the on/off switch while turning it on. the eSC should beep. hit the button again. then pull full throttle on the radio and hold and hit that button a 2nd time. (again, have the truck off the ground when doing this) Now apply full brakes and then hit the button a 3rd time.
    Release the radio trigger. turn off the car and then the radio.

    Of course, you must have the ESC plugged into port #2 on the receiver as Redcatbilly said.
    turn back on and see if it works.
    SC10rs, 1/6 hummer crawler, Kyosho Twin Force, Lunchbox project, Techone P51,

  8. #8
    Thanks but it seems to still not work im going to post a vid up again of me doing the steps that you instructed me to do!

  9. #9

  10. #10

    Join Date
    Apr 2010
    Location
    Phoenix, AZ
    Posts
    7
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Thank you for the video. If you can, please give me a call directly here at our shop (with your vehicle and radio in front of you) within the next hour, and I will gladly help walk you through everything. There is a chance that something else may be wrong, and we can walk through some more troubleshooting. (602) 454-6445.

    Thanks,
    Billy

  11. #11
    [QUOTE=joed23;11661334]Hellp again please! http://youtu.be/CHLYhYyv1VM[/QUO

    Sounds like you have the same issue as I did I called redcat racing and it was determined to be my ESC that was the problem they sent me a new one no questions asked and it was shipped quick and my Sandstorm is was back in running condition that was the problem now I broke something else as now it barely moves guess I stripped the spur gear have to tear into it and figure what I broke. Redcat support was awesome with the ESC troubleshooting give them a call I'm sure they will help you out.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 03:37 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.