Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1

    Join Date
    Jan 2014
    Location
    Minnesota
    Posts
    6
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    redcat caldera 10e power problems

    When I run at full throttle for about 20 seconds the power downgrades to about half throttle for about 10 seconds then completely stops. If I let it sit for a few seconds then try it it starts back up but then starts all over again. Any suggestions please help.

  2. #2
    Sounds like the low voltage cut off in turned on. Its just a setting on the esc that can be adjusted quickly and easily. Here is a link to one of our esc's and at the bottom is the instruction manual you can download and readjust the setting. http://www.redcatracing.com/03351
    Or you can just give us a call (602)454-6445

  3. #3

    Join Date
    Jan 2014
    Location
    Minnesota
    Posts
    6
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Thanks for the help will give it a try


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 09:20 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.