Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

redcat caldera 10e power problems

Reply
Old 02-08-2014, 11:27 AM
  #1
joshcarter58
Thread Starter
 
Join Date: Jan 2014
Location: Minnesota
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default redcat caldera 10e power problems

When I run at full throttle for about 20 seconds the power downgrades to about half throttle for about 10 seconds then completely stops. If I let it sit for a few seconds then try it it starts back up but then starts all over again. Any suggestions please help.
joshcarter58 is offline  
Reply With Quote
Old 02-12-2014, 08:15 AM
  #2
Redcat James
 
Join Date: Feb 2014
Posts: 77
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Sounds like the low voltage cut off in turned on. Its just a setting on the esc that can be adjusted quickly and easily. Here is a link to one of our esc's and at the bottom is the instruction manual you can download and readjust the setting. http://www.redcatracing.com/03351
Or you can just give us a call (602)454-6445
Redcat James is offline  
Reply With Quote
Old 02-17-2014, 09:25 AM
  #3
joshcarter58
Thread Starter
 
Join Date: Jan 2014
Location: Minnesota
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Thanks for the help will give it a try
joshcarter58 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 02:36 PM.