Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

RS10 Rockcrawler - front steering issue (stuck, fully engaged, maxed out by the ESC)

Reply
Old 04-07-2014, 06:11 PM
  #1
noridetoolow
Thread Starter
 
Join Date: Apr 2014
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RS10 Rockcrawler - front steering issue (stuck, fully engaged, maxed out by the ESC)

Got this for my boys for their bday last week. My twin boys played with it maybe 5 hours max and the front steering became stuck. Ok let me clarify. When you turn on the power to the truck (regardless of if the remote is on or not), the front wheels turn fully to the right and cannot be moved, the steering box is fully engaged and vibrating like its still trying to turn. When you turn the power off to the truck the servo frees back up and I can turn the arm on it which straightens the front wheels back up so its NOT the suspension sticking or getting stuck.SO....the ESC seems to be sending a constant "turn right" signal to the front servo\steering box. Is there a way to reset the ESC? Has the esc already failed?? I had better hopes for this thing and my boys who just turned 12 are dissapointed.

Thanks all
noridetoolow is offline  
Reply With Quote
Old 04-07-2014, 07:06 PM
  #2
zackS30
 
zackS30's Avatar
 
Join Date: Oct 2013
Location: Peoria, AZ
Posts: 1,061
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

The stock servos are absolutly terrible. U can try taking it apart and looking at the gears specificly the one thats had tge arm attached bcuz it has a peice on it that tells the servo if its straight or not.
Get a better servo, hitec 645mg is a good one. It has metal gears and like 160oz torque. I have one on my rs10 I have an exi 227 something. The hitec cost me 35 and the exi was 25. The hitec IMO is better. Nothing wrong with the exi though.
zackS30 is offline  
Reply With Quote
Old 04-08-2014, 04:23 AM
  #3
noridetoolow
Thread Starter
 
Join Date: Apr 2014
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Quote:
Originally Posted by zackS30 View Post
The stock servos are absolutly terrible. U can try taking it apart and looking at the gears specificly the one thats had tge arm attached bcuz it has a peice on it that tells the servo if its straight or not.
Get a better servo, hitec 645mg is a good one. It has metal gears and like 160oz torque. I have one on my rs10 I have an exi 227 something. The hitec cost me 35 and the exi was 25. The hitec IMO is better. Nothing wrong with the exi though.
Thanks, I will def look into that. I figure the ESC probably has a separate output (Plug) for the front vs rear so I should be able to swap those and see if it moves to the rear or if it stays up front. I'd rather change out that servo than the ESC though...cost wise and all.
noridetoolow is offline  
Reply With Quote
Old 04-08-2014, 01:41 PM
  #4
zackS30
 
zackS30's Avatar
 
Join Date: Oct 2013
Location: Peoria, AZ
Posts: 1,061
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Yeah try that. Ch1 is front servo ch2 is throtle ch3 is rear servo.
Rc4wd outcry is the esc I was going to get for mine I saw one on ebay for $60(u.s dollars)
zackS30 is offline  
Reply With Quote
Old 04-08-2014, 05:09 PM
  #5
noridetoolow
Thread Starter
 
Join Date: Apr 2014
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

swapped the channels and it still hits the front servo so....its bad. I took it apart and hooked it up, when it gets power it just spins non-stop. Sadly this is not even a condition of abuse, it apears to me to be an electrical issue in the servo which is sad considering how little use this thing has.
noridetoolow is offline  
Reply With Quote
Old 04-09-2014, 11:48 AM
  #6
zackS30
 
zackS30's Avatar
 
Join Date: Oct 2013
Location: Peoria, AZ
Posts: 1,061
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

The servos are garbage. Get a hitec servo from ur local hobby store. Metal gear high torque
zackS30 is offline  
Reply With Quote
Old 04-09-2014, 11:57 AM
  #7
noridetoolow
Thread Starter
 
Join Date: Apr 2014
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Quote:
Originally Posted by zackS30 View Post
The servos are garbage. Get a hitec servo from ur local hobby store. Metal gear high torque
Yeah I found the one mentioned above in another comment on ebay for $29 shipped, I will order one for the front tomorrow and be on tap to order another soon

Thanks
noridetoolow is offline  
Reply With Quote
Old 04-09-2014, 03:45 PM
  #8
zackS30
 
zackS30's Avatar
 
Join Date: Oct 2013
Location: Peoria, AZ
Posts: 1,061
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

No problem.
zackS30 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:18 PM.