Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Redcat Tornado S30 Problems

Reply
Old 04-28-2014, 09:05 AM
  #1
510MotorHead
Thread Starter
 
Join Date: Apr 2014
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Unhappy Redcat Tornado S30 Problems

So I recently purchased a tornado s30 by redcat and have had 2 major problems, first off is the idle of the car. Since the first start I've been unable to adjust the idle to where the tires dont spin, I've made the gap in the carb as small as the idle screw will let me and still the engine revs super high making the tires spin??

Also after the break in process I ran it a couple times and was able to drive it fine then all of a sudden the car just stopped moving, the engine was still running and revd up when I gave it throttle but it would not go any where. I'm guessing the high idle speed wore out the clutch whenever I hit the brakes but am not sure completley.. If theres any advice or anyone who knows the reason for these problems I would GREATLY appreciate it. Thanx
510MotorHead is offline  
Reply With Quote
Old 04-29-2014, 03:38 AM
  #2
garry125
 
Join Date: Jan 2014
Posts: 9
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

did you adjust idle on controller?
garry125 is offline  
Reply With Quote
Old 04-29-2014, 10:48 PM
  #3
zackS30
 
zackS30's Avatar
 
Join Date: Oct 2013
Location: Peoria, AZ
Posts: 1,061
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Check the settings on the controller.
If its reving really high then its too lean.
If u put it on the.ground and it doesnt move when u hit the gas then the clutch may be gone, its plastic so upgrade to the alum. one.
zackS30 is offline  
Reply With Quote
Old 04-30-2014, 06:24 AM
  #4
osubuckeyesgsxr750
 
Join Date: Mar 2014
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

The revving tires is completely normal and this happened to me as well. If the cap is only 1mm then try adjusting the low speed needle counter clockwise and richen it out some.

Please check your remote and make sure the throttle trim (middle nob that reads (Th Trim) isn't too high. I keep mine at where the indicator is (arrow). I also increase the throttle trim and it will help you start your. Buggy but turn it down after starting.

The reason if won't rev:
I also had this same issue and I found my issue was I stripped the spur gear. I did this because of the results from your first problem with the tires/motor revving so hard. If you so not keep the wheels of the ground this will cause a lot of tension and strip that gear. It happened to me and redcat even told me that was the cause. please don't worry as these are two minor issues. Can be prevented.
osubuckeyesgsxr750 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 03:26 AM.