Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Earthquake 3.5 prone to breaking?

Reply
Old 08-24-2014, 03:14 PM
  #1
conman888555
Thread Starter
 
Join Date: Aug 2014
Posts: 5
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Earthquake 3.5 prone to breaking?

ok so i just got an earthquake 3.5 and right off the bat i had a problem...the piston was stuck...solved by a hair dryer set at max heat...so i then go through the first break in tank (idle) and then another idle. i take it out for the first break in run and discover my brakes are not working. i look at the brake disc and what do you know! the disc was stripped on the inside. fine it wasn't in the way so i proceed to drive it cautiously. got through the first break in run and notice there are only two wheels moving...again i check and the link from the gearbox to the drive line in lose and is just wobbling around. i take it into my shop and take out one brake pad screw and manage to get the disc and link out. next i re install the link with no brake, tighten the grub screw on it, and put the screw back on the brake pads. Take finish the second and final breaking run and AGAIN there is no front wheel drive. i go back and the same problem. i fix it the same way making to tighten the same screw again. now i go through a little maiden run in the backyard and it seems to work fine. now i go and drive around a field to my liking of speed and it flips (due to bad receiver connection and slow throttle servo) and it is only running two wheel drive AGAIN! But this time there is no link. i replace the batteries in receiver and drive with two wheel drive. now my dad drives 30 min to go get the link and a steel brake pad and he gets the rear link (my fault) and i go back out to get the truck and the back link in now rolling around on the bottom and both front and back drive lines are disconnected from the gearbox. Why is this happening????? do regular trucks have this problem????? did do something wrong???? what can i do to stop this drive-line link from loosening? why did the brake strip? and i never did any huge jumps just running over some pool noodles and i stopped jumping as soon as the link loosened. THANK YOU FOR READING THIS!!!!
conman888555 is offline  
Reply With Quote
Old 08-24-2014, 08:12 PM
  #2
FatNinja
 
Join Date: Aug 2014
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Can't say they are prone to breaking, just made in china. But I can say you should contact selling dealer and redcat about these problems.
FatNinja is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 07:42 PM.