Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 2 of 2

  1. #1

    Sandstorm Baja Buggy - Worked for few minutes, now just beeps for about 10 seconds

    Folks,

    Brand new to RC. Got a Sandstorm Baja buggy as a gift. It worked when I first charged it. Only used it for about 2 minutes as was busy.

    Went back to try it out and it only beeped a couple of times and did nothing.

    Research seemed to say the throttle calibration got wacked. But tried to recalibrate with the hold trigger full, 3 beeps then stop, then brake 3 beeps then stop etc.

    But the beeping never stopped.

    Even worse now when I turn it on, it does about 10 seconds of "clicking type" beeps and then the beeping stops and nothing. While it's beeping it kinda looks like it's pulsing
    the motor.

    Totally stuck now, brand new...any idea's. How can I test just the ESC independent of other things etc.

    Thanks

    NR_Gamer

  2. #2
    zackS30's Avatar
    Join Date
    Oct 2013
    Location
    Peoria, AZ
    Posts
    1,039
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Do u happen to have a spare motor laying around that u know works?
    Axial poison spyder wraith, axial exo terra, axial scx10 honcho, 13 xmods
    Fav. Quote... Only the dead have seen the end of war- plato


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 04:51 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.